Bootloop after install, black screen

Hi, I’m new to Qubes and i’m decided to use it as my main OS (along with windows, on separate m2 drives), but this is not being easy.

I tried with Qubes-20210904-kernel-latest-x86_64.iso because 4.0 were unable to install, now I can install the system but it bootlops right after. So I followed the steps here (because my boot/efi/EFI/qubes folder was empty, I copied the initramfs and kernel files here too) and here (because the /BOOT folder was also empty and the first solution didn’t work) but with no luck, the screen goes black just the same and it restarts. I tried with the “modprobe.blacklist=nouveau , rd.driver.blacklist=nouveau , nouveau.modeset=0 , efi=no-rs” options at grub but didn’t work either. Here is my created xen.cfg file, maybe there’s something wrong (I’m not experienced linux user if you wonder):


options=loglvl=all dom0_mem=min:1024M dom0_mem=max:4096M
kernel=vmlinuz-5.13.13-1.fc32.qubes.x86_64 root=/dev/mapper/qubes_dom0-root i915.preliminary_hw_support=1 rhgb quiet

My hardware is
-AMD Ryzen 5 4650G Pro

Any help is appreciated, I’ve been struggling with this for a few days now

Getting a problem which may well be the same as you do, see

5.12.14-1.fc32 mostly works on my machine, though resuming from suspend is still not working (which is why I’d like to check a newer kernel, but as always I’m rather putting my hopes in the upcoming suspend fixes in 5.15…)

try editing grub loader add i915.force_probe=* after rhgb quiet.
and adding those file / xen.cfg would be useless if your bootloader is point to /EFI/qubes/grubx64.efi

Is you bios in UEFI mode? I had the same problem where it didn’t install the boot files and instructions.

I’m on my 3rd week using Qubes. I was able to install it with the bios in legacy mode but I spent the 1st week figuring out why I couldn’t boot with the bios in UEFI mode. I had to piece together various solutions to make it work. The key solution didn’t state which path you needed to be on.

  1. Setup bios to UEFI
  2. Run the Qubes installation and stop before pressing the Reboot button near the end.
  3. Press Ctrl+Alt+F2 to get to the anaconda screen.
  4. cp -r /mnt/sysimage/boot/efi/EFI/qubes /mnt/sysimage/boot/efi/EFI/BOOT
  5. rn /mnt/sysimage/boot/efi/EFI/BOOT/xen.cfg /mnt/sysimage/boot/efi/EFI/BOOT/BOOTX64.cfg
  6. rn /mnt/sysimage/boot/efi/EFI/BOOT/xen.efi /mnt/sysimage/boot/efi/EFI/BOOT/BOOTX64.efi
  7. Press Ctrl+Alt+F6 to get back to the Qubes installation screen
  8. Press Reboot
  9. Remove the installation USB drive

Continuing the discussion from Bootloop after install, black screen:

First of all sorry for being late!

@yann It looks pretty similar, at first i thought it was something relationated with amdgpu or the renoir arquitecture, but now im writing from a DispVM with no issues, and the hardware seems to be working good, uefi mode. I just downloaded 5.10.61-1.fc32.qubes.x86_64 (NOT latest kernel this time) from Index of /qubes/iso/ (sorry for no exact link but site’s down right now) and it installed and booted flawlessly, it gave me a firewall error at first but sys-firewall seems to be working good.

@51liel By luck I had no time to test your solution, the clean install with the anterior kernel did the trick. I tried to recreate the BOOTX64.cfg files also, as described on the 2nd solution on the op, I don’t remember if I tried with all the directory… Thanks anyway

@ joe.blough yes UEFI mode, I’m unable to reproduce the steps as now I have the installation up and running, but I think I already tried that steps and I appreciated that the kernel and initramfs files were missing. Also the successful installation showed me messages about copying files that, with the latest kernel, I didn’t see

Easy solution, hard time with it, things you gotta learn when you change so much your computer interaction I guess, now with a fresh running installation I can tell, this is what I wanted, this feels glorious, I can’t wait to setup my vms and get used to this, there’s a lot to learn here. Amazing community and amazing work