Booting to a blank screen after xen hypervisor prompt but before disk decryption

Hi everyone,

I have checked the prompted replies and have searched but I can’t seem to find the exact problem so apologies if I missed it.

I just tried installing the linux .deb package of teams on my debian 11 template and made it accessable to a “work” qube I created (I know, I’ll teach me to try putting anything from microsoft onto a proper operating system but I have to use it :frowning: ). The install seemed to go ok and I tried to use it and it started up but hung. Ok so I’ll just use it on my windows machine instead, no biggie.

I uninstalled it from the debian 11 template and removed it from the work qube. Now on booting up the system the splash screen comes up asking me if I want to boot with xen hypervisor or with advanced options… if I select hypervisor the screen goes black (like it used to before the prompt to enter password to decrypt the hard disk) but then it stays black, the monitors “no signal detected” message comes up and it stays black screen.

If I use the advanced options and choose the 1st option in the list the same problem occours but if I use the second option then I get the password prompt and get logged in just fine, no problems.

This only started happening after I tried installing that teams garbage and I think I’ve got rid of it now but I would like to just let the machine boot up with no problems like it used to before.

Any help in sorting this out would be appreciated.

I took some pics on my phone of the screens I see if that helps at all

1 Like

Did you update the dom0 in the session when you’ve installed your app in template?
It seems that you’ve updated dom0 and new kernel version was installed in dom0.
And this new kernel version has some issues with your hardware.
What Qubes OS version do you have? 4.1 or 4.2?
What’s your hardware?
What is the name of the GRUB boot menu option that worked for you? There should be specific Xen and kernel versions there.
What is the name of the GRUB boot menu option that didn’t work for you? There should be specific Xen and kernel versions there.

1 Like

Thanks for your reply.

Yes! I do recall there being a dom0 update that took quite a while around the same time.

I’ll start pulling together all the information asked for. Is there a command I can use to grab hardware information? Sorry I’m a bit of dullard with finding that sort of thing out. I can get the kernal versions from the start screen when I boot in

In dom0 Q → gear icon → Qubes Tools → Qubes Global Config → This device tab.

Thanks, got that now.
Ok I am in qubes 4.1
Xen hypervisor is verion 4.14.6
Dom0 updated to Linux 6.8.6-1 - This is the option that won’t properly book up and black screens.
The next option down, which is Linux 6.6.2-1 boot just fine.

I can’t find a hardware tab or anything in the setting to identify exactly which processor or graphics card I’ve got or anything though

I hope that helps

Is there no information about your CPU/Chipset/GPU in “This device” tab?
In that case can you copy HCL report from “This device” tab and paste it here?

Since the most recent dom0 updates I have been facing a similar issue. I boot into qubes and after loading xen, no display output is provided. I have found that removing the ‘plymouth ignore serial consoles’ portion of the grub command line functions as a work-around, and allows me to input my disk password and successfully boot into the system using 6.8.6-1 kernel. Kernels prior to 6.8.6-1 function normally.

Played with this a little further - In my case, I think it’s simply a rendering issue. Inputting my disk password into the blank screen after waiting ~5 seconds or so and pressing enter causes the system to boot successfully.

I followed your directions to the letter. I have qubes tools but there is no Qubes Global Config in the menu after that so I’m un able to get to the “This Device” tab

Maybe it’s not available in Qubes OS 4.1 and it’s only present in Qubes OS 4.2+.
I’d suggest to update your Qubes OS to version 4.2 and see whatever the problem will go away.
The Qubes OS 4.1 will stop receiving support in June so it’d be better if you update the system soon:


I’ll read the guide on how to update to 4.2 and get that underway asap. It might sort it out.

Thanks for all the help people