Boot stuck at warning "USB in dom0 is not restricted"

I attempted to upgrade from 4.1.2 to 4.2.0 using
sudo qubes-dom0-update -y qubes-dist-upgrade and then
sudo qubes-dom0-update. The second command downloaded quite a lot and I was prompted to restart. Afterwards it seemed to start normally but after entering in my password to decrypt the disk, it displays the warning “USB in dom0 is not restricted” and is stuck there. I am used to seeing the warning before but never seen it get stuck at this point.

I attempted to get some more info by removing ‘quiet’ from the grub configuration at launch and also added ‘nvme_core.default_ps_max_latency_us=0’ and ‘transparent_hugepage=never’ and ‘usbcore.authorized_default=0’

Here is the output I see.

Seems like some problem with GPU or lightdm (audit lightdm res=failed).
Are you able to switch to another TTY with e.g. Ctrl+Alt+F2?

I seem to be able to get to the terminal. Trying to restart lightdm results in the same problem. I think the problem stems from all the packages not getting updated due to a problematic library. The reason why I think that is if I try to do “sudo dnf update” from dom0 I get the same issue reported here.

You need to use qubes-dom0-update script instead of dnf:

I’ve done that. It completes but I don’t see it doing much even with the ‘–verbose’ tag added. My understanding is that the script behind this command runs ‘yum update’. If I try ‘yum update’ on its own I run into the same problem with running dnf.

There is no network in dom0 so it’s expected for them not to work. That’s what the script is for.

Seems that it can’t connect to the fedora mirror site for some reason.

Maybe there is no internet in your dom0 update qube (sys-firewall).

That appears to be correct. I ran 'qvm-run --pass-io --verbose --no-gui sys-net ‘sudo iwconfig’ and it only came back with lo and vlf3.0. So no wireless interface and unfortunately my laptop which has the qubes installation has no ethernet port. I tried using the rescue ISO but apparently that has been broken for quite some time and is still not fixed. So now I am at a bit of a lose as of what to do other than reinstall and lose my VMs.

You can try to change the sys-net template. Maybe in other templates your wireless controller will be initialized successfully.
You can also check the sys-net log to see the specific error with your wireless controller.

You can copy the VMs disks and recover the files from them manually even without rescue mode.