Boot Issue - not asking for passphrase, can't open blockdev

after an update, Qubes OS just bootloops. removing the quiet param reveals that it’s unable to mount the root device.
Though it stopped prompting for a disk encryption password.
things checked:

  • rd.luks.uuid is matching /dev/nvme0n1p3 (default setup)
  • root lvm partition is ‘ACTIVE
  • mounting the partition in “resuce mode” by hand (cryptsetup) works

This install used to work fine.

Qubes Version is 4.1.2

Could it be the initramfs is missing luks and/or lvm support?

here are some log message (typos due to google lens text ocr):

md: ... autorun DONE.
4.7495681 /dev/root: Can't open blockdev
4.7588751 VFS: Cannot open root device "mapper/qubes_dom0-root" or unknown-block(0,0): error -6
4.7521741 Please append a correct "root" boot option: here are the available partitions: 
4.753488) Kernel panic not syncing: VFS: Unable to mount root fs on unknown-block(0,0) 
4.7547741 CPU: 1 PID: 1 Conn: upper Not tainted 6.1.42-1.qubes.fc2.6 f

Is the initramfs different in case of rescue mode?
If no then the cryptsetup and other commands (maybe) wouldn’t work.
If it is different you can drop to a shell and try them manually to see if the commands/binaries are present. i.e. try a normal boot first but drop to a shell and try to mount the partition manually and continue boot.

There is the lsinitrd command you can run from within the OS to see if and how initramfs files are different.

For further debugging try:

can’t drop into a shell using unfortunately, maybe a qubes specific issue?

rescue mode is booting a qubes iso (on a usb stick) and selecting “rescue broken qubes install”

rd.break=cmdline does not help either…

not sure what to try next :man_shrugging: