Boot from removable grub

I have been trying for the life of me to install the qubes bootloading process on a USB since I want to install the luks keyfile on initramfs and I do not trust the security of my propriitery uefi system and boot from there,
the way I have tried it and epicaly failed, if you have prior experiance and done this before I would love a link to a guide, atm what I have done is this:
mount /dev/sda1(usb-device) on a fresh sys-usb and mount to (sys-usb)/boot, grub2-install --target=x86_64-efi --efi-directory=(sys-usb)/boot --removable, later sudo fdisk /dev/sda → advanced → bios bootable(/dev/sda1 is fat32 formated partition for reference, what worked with gentoo in the past at least), create a tar with (dom0)/boot and qvm-copy-to-vm sys-boot, unextract and copy all files but grub2/grubenv to (sys-usb aka /dev/sda1)/boot for testing
boot from usb… seccess
boot back on and remove original ssd grub and efi partitions (backed up as well ofc)
reboot and boot from usb again… fail
boot to usb grub 'e’dit and I started playing around with ‘hdX,gptY’ values,
problem is the values(after I change them) should be correct
if I f2 and go to grub console i can ls (hd0,gpt1) and I see my first partition of the usb correctly
When I go back on grub and change the values to hd0,gpt1 it still fails not being able to find any files, kernels etc

Untested, but I guess you need to:
Attach your USB to dom0, create EFI System and /boot partitions on this USB.
Copy files from your old EFI partition to the new one and from old /boot partition to the new one.
Edit /etc/fstab and change the EFI System and /boot partitions UUIDs.
Mount the new partitions to the /boot and /boot/efi.
Run grub2-update to regenerate the grub config with new UUIDs.