Blueman Bluetooth headset confusion


I was able to install blueman without any error message in sys-net. Bluetooth adapter recognized when using lsusb in sys-usb. However, I’m still not seeing the bluetooth tray or icons. I’ve searched the forum first, but I’m really confused as some seem to install it in the VM they want to use the USB headphones in and others install it to sys-net. Which one is the correct one and the one that provides the most privacy even though I understand a wired headset would be preferable(keyboard and mouse wired)?

What can I do to troubleshoot the bluetooth icons not appearing?

Thank you!

I am assuming that you are using bluetooth for audio. Please correct me if this is not the case (ex.: for file transfer).

In this case, it is not secure to use bluetooth with audio in dom0. Please consider configuring sys-audio, for which there is an awesome guide here:

IIRC, this guide includes bluetooth, and securely.

1 Like

Add and enable the blueman service in the sys-usb Settings → Services tab.

But you’ll need to create audio qube as described in the guide linked by @XMachina so other qubes would be able to use the headset. Or you can configure sys-usb to be audio qube.

1 Like

thank you so much I figured it was not safe to install this in Dom0. I will proceed with your guide. Many thanks!

Perfect I will follow this guide and enable blueman and add the services tab. Thank you!!!

Glad to help. Please don’t forget to mark this as solved when you confirm it works!

I did. I made it all the way to the end but sys-audio wont start because USB controller is used by sys-usb.

Did you set it as disposable template in its Settings → Advanced tab?

1 Like

i did. I managed to make it all the way to the end but sys-audio wont start because USB Controller is used by sys-usb.

You can remove USB controller from sys-audio and attach only USB bluetooth device from sys-usb to sys-audio.

I just did. when starting sys-audio I get the error message "has failed to start unable to reset PCI device “my audio device” no FLR, PM reset or bus reset available

Did you remove PCI USB controller from sys-usb and attached it to sys-audio?
If that’s what you want to do then enable no-strict-reset for this PCI USB controller in sys-audio:

But you can also leave all your PCI USB controllers in sys-usb and attach just bluetooth device using Qubes Devices widget in tray from sys-usb to sys-audio.

1 Like

thanks you so much to both of you. Now everything seems to be working with no-strict reset