Block Devices Not Accessible from Windows Qubes

Attaching “Block-Devices” from the sys-usb to windows qubes (tested on 7, 10 and 11) seemingly results in nothing. Not able to see the device inside the windows qube even though it shows attached. This happens to internal HDDs and any connected external USB HDDs which appear under Block Devices in sys-usb.
Attaching flash drives, that appear under “USB-Devices” in sys-usb to the windows qube, works well, and are accessible.
I have followed all recommendations from qwt installation guide. Is there anything that needs to be done for this after qwt installation? Maybe some controller assignment in qubes settings?

Did you try with qvm-block attach --persistent prior to boot them?

No, but these are not bootables.
These are just data disks which show up as block devices.

Prior to boot Windowses

qvm-block attach --persistent win7 sys-usb:sda

Thanks. This should work I guess since it is working from the gui. It helped me notice that this happens with the internal drive that shows up only under Block-Devices connected to dom0 (please see image).


The sys-usb:sda under Block-Devices is the same as sys-usb:3.2, but it gets connected only when I attach the sys-usb 3.2 to the windows qube.
This happens only to Windows qubes and not with the debian11/fedora36 appVMs, which attach all devices easily as expected (i.e., nvme0n1 gets attached on d11/f36 qubes but not windows qubes).

By the way, should I do something about the internal drives auto-connecting(? am not sure if this is connection at all, or recognized by dom0/sys-usb) to dom0? Should this be a concern, drives connected to dom0 automatically?

Is this method confirmed to work or am I doing something wrong? The device is still not visible from both Windows Explorer and Rufus, which I wanted to use to burn a Windows ISO on a USB drive.

This works with windows qubes only after qwt installation. But then only block devices attached to dom0 fail to be recognized in windows qubes even after qwt installation.
I need to know how to prevent the internal HDDs/NVMes from attaching to dom0 on boot.

Edit: The sys-usb:sda under Data Block Devices is the same as dom0:sda, but doesn’t show up in windows qubes + qwt.
sys-usb3-2 which show up under USB Devices attaches to windows qubes.
So essentially any device under DATA (BLOCK) DEVICES is not attaching to windows qubes.
Even this command before booting the qube didn’t work.
qvm-block attach --persistent win7 sys-usb:sda

It’s

qvm-block attach --persistent win7 dom0:nvme0n1

qvm-usb attach --persistent win7 sys-usb:sda

both don’t work?

Thanks. Sorry I got a bit busy.
The command for sys-usb:~ works only if the device is listed under the USB devices category; if the sys-usb:~ is listed under Block devices, it doesn’t work. For dom0:~ devices, it doesn’t work. And this is only for the Windows qubes, with qwt of course. (I wonder if somebody is able to replicate and confirm it as a bug/issue, or am I doing some silly mistake in configuring QOS properly?)

So I will need two things:

  1. Prevent internal drives from being recognized automatically as block devices associated to dom0. (I am guessing this is happening because of sys-usb)

  2. How to remove them from that dom0 list, so that they can be recognized again in the USB devices list (if this is possible at all)?

Thanks again.

EDIT: Both (idea/question) seem incorrect. I think we must identify what is the issue with attaching the internal drives to the windows qubes, when the same is possible with all other debian/fedora based qubes.

Looks like a known issue. To be able to use USB devices it’s recommended that one install a certain driver and pass the device as USB device. I experimented a bit and wrote some information on that:

After Qubes Windows Tools have been installed on your Windows 7 system, please install the Chipset_Driver_X2NF0_WN_2.1.39.0_A03.EXE driver. Then shut down your domain.

From now on you should be able to attach your USB drive by passing it from your Qubes Devices menu as a USB device rather than Data (Block) Device

This procedure has been tested on Windows 7 installed as a TemplateVM. Different combinations (such as StandaloneVM or different Windows versions) have not been tested.

That’s the funny part. For me the USB devices and file copy work fine. Only devices under Data “Block” Devices fail to be recognized on W7,10 and 11 with QWT, on attaching.
I will still try your trick (or something similar) and post the results.
Need some time.
Thanks anyway.

Thanks.
I have no problem with external USBs/HDDs (“USB Devices”) - they are accessible from windows qubes.
The problem is with a couple of internal hard drives (1TB Nvme and 1TB SSD) that get auto connected to dom0, and when attaching them to the windows qubes appears to be successful from the applet, they fail to be recognized inside the Windows qubes .
I am wondering if I need to assign some (?PCIe) device controller to windows qubes from the qube settings? I am not sure which one, so haven’t experimented yet.

Yo haven’t respond if you tried

IT is needed to attach it prior to boot… sys-usb has nothing to do with internal block devices, so you’re bringing confusion mentioning them and trying to mount internal devices wit qvm-iusb command

Sorry for the delay @enmus, got a bit busy.
qvm-block attach --persistent win7 dom0:nvme0n1

used correctly in the dom0 terminal before booting the qube, doesn’t work. After the command the Qubes Devices applet shows that the block device is attached to the win qube, but inside the win qube nothing is attached.

qvm-usb attach --persistent win7 sys-usb:sda
I don’t need this because devices listed under USB attach without any problem when processed from the sys-usb gui.

Did you install those chipset drivers as @aronowski wrote?

https://web.archive.org/web/20221007093126/https://dl.dell.com/FOLDER01557883M/3/Chipset_Driver_X2NF0_WN_2.1.39.0_A03.EXE

It is mandatory for windows 7

How do you know Windows didn’t recognized attached drive? Did you check it in Computer Management?

I tried installing the chipset driver too, just in case; didn’t work.
I always check failed attachments with devmgmt.msc and Computer Management > Disk Management.
But then, it is a chipset driver that adds a USB 3.0 utility, and so far I do not have any problems with attaching USB devices that get listed under the “USB Devices” section in the Qubes Devices applet.

The problem is with devices that are listed under “Data(Block) Devices” in the Qubes Devices applet, it doesn’t matter if it is dom0:nvme0n1, dom0:sda, or sys-usb:sda - as long as they are under this section, they don’t appear inside the win7/10 or 11 qube after assigning from the gui.