Black screen with a "-" right before the installer GUI

I have an AMD advantage laptop (Ryzen 9 5900HX CPU and Radeon RX 6800M GPU) and I flashed the ISO file using Rufus (dd). The problem I am facing is that right before the installer GUI, I get a black screen with just a “-” displaying at the top left corner and then the installation process freezes.

I tried following the UEFI troubleshooting guide but in the latest ISO I could not find a “BOOTX64.cfg” file in the /EFI/BOOT folder. That directory only contains a “fonts” folder, a “BOOTX64.EFI” file and a “grub.cfg” file.

PS: I am not that technical.

I think the BOOTX64.cfg was for Qubes OS 4.0 – if you are trying to install Qubes OS 4.1, grub.cfg is what you should be looking for.

The simple way to change boot options on Qubes 4.1, is to press e at the boot menu, to edit the arguments to the kernel/XEN.

You could try and replace quiet with module_blacklist=amdgpu – it’s just a guess but it might give more info.

1 Like

This worked and now it shows the GUI. Thanks a lot :slight_smile:

Another question though. I have a previous installation of Qubes (it was installed around 7 - 8 months ago and not updated since) and now that too is not booting up past the text info screen (sorry, I don’t know what it’s called). This time it shows a completely black screen.

Can you share what’s on the “text info screen”? - do you recall, if it was a Qubes OS r4.0 or Qubes OS r4.1?

I guess it’s called the boot screen and I believe it was Qubes 4.1 since final 4.1.0 release was on 2022-02-04 and I downloaded the latest version at the time of installation. On the boot screen it says XEN_VERSION = “xen-3.0”.

Screen goes completely black after it says “Xen is relinquishing VGA console.”

Edit: I downloaded “Qubes-4.2.202303150603-x86_64.iso” from Index of /qubes/iso/ and created a bootable USB using it and in this version, the GUI installer opens directly without the need of module_blacklist=amdgpu. Maybe that is some useful information?

That sounds strange – the Qubes OS 4.1 release notes | Qubes OS says:
Xen upgraded to version 4.14

and the Qubes R3.0 release notes | Qubes OS says: Xen 4.4

Can you use the e to edit the boot menu the same way on the old installation? - if so, can you navigate to the kernel line, simply remove quiet and try to boot?

I would expect the Qubes OS 4.2 weekly to work better than the 4.1.x - I think it defaults to a Linux 6 kernel … and those has way better support for Ryzen CPUs. :slight_smile:

I unfortunately do not have the old installation ISO file. I can access the old installation USB using rescue mode (on another USB) though.