Black screen on Inspiron 5415

Hi, I recently get my new laptop, a Dell Inspiron 5415, and want to install Qubes. First I tried with 4.0.4 but it didn’t work so I followed the steps on the troubleshooting page, same. Then I started to read the same issue on reddit, github and this forum and I tested every things I found. I also tried with weekly builds but same problem.

Now I’m running Fedora 34 which works fine. From what I understood this would be CPU related, a Ryzen 5 5500U. Can anyone help me ?

Hi, welcome to the community! It seems your hardware is too new for the old Fedora in Qubes 4.0. Did you try 4.1? It is still being tested though, not a stable release.

Yes, I tried with Qubes-20210612-x86_64 and Qubes-20210717-x86_64 normal and lastest-kernel but same black screen.

1 Like

Just to be sure, kernel parameter i915.alpha_support=1 hasnt helped? Disabling TPM and SecureBoot (in BIOS) too?

I was to post a question about experiences with AMD Ryzen 5000 CPUs / Laptops so thats a little show stopper to me -_-

i915.alpha_support=1 is already set with 4.0.4, SecureBoot was disabled and I just tested with TPM disabled but nothing works.

However, the author of this post managed to install it with the same proc.

Strange, there isnt mentioned any special method how to get qubes installed, notably R4.0.4, and I would assume you tried that already. Did I miss something?

Yes I tried with same parameters as him :

I am running just latest updated 4.0.x release of qubes (other than the changes noted above), using UEFI, and I had to remove the noexitboot and mapbs options from BOOTX64.cfg file to be able to install (to get the installer to come up).

But I didn’t see any difference.