Black screen before entering your LUKS decryption password

Getting a black screen when just before i get to the Luks encryption screen. This happens when using 1x 4k monitor connected to PC via HDMI. When I use a standard monitor it all works.

To fix it I tried this command in DOM 0 terminal

qvm-features dom0 gui-videoram-min 650000
to give it extra ram to video memory but no luck.

Monitor is a LG 42inch C2 Evo
PC is a NitroPC

Just tried this but no luck

Post installation, screen goes black and freezes following LUKS decryption

After installing Qubes, you may experience a black screen after entering your LUKS decryption password. To fix the problem, use your preferred text editor ( nano works) to edit /mnt/sysimage/boot/efi/EFI/qubes/xen.cfg , adding the efi=no-rs option to the end of the options= line . For example:

[4.14.18-1.pvops.qubes.x86_64]
options=loglvl=all dom0_mem=min:1024M dom0_mem=max:4096M iommu=no-igfx ucode=scan efi=no-rs

Note that the /mnt/sysimage/boot/efi/EFI/qubes/xen.cfg path applies when running from the installer (either directly after installation, before the reboot, or by starting the installer again in recovery mode). On the actual installed system, the file to edit is /boot/efi/EFI/qubes/xen.cfg – but it may be hard to access directly when your system won’t boot.

Underneath the /mnt/ directory this is no other directory and under /boot/efi/EFI is locked with no access

I guess you found the suggestion on:

Last commit to that page was on 2021-07-09 - so it probably relates to QubesOS 4.0(?) - can you try:

[dom0]$ cat /etc/qubes-release

?

Underneath the /mnt/ directory this is no other directory and under /boot/efi/EFI is locked with no access

Did you boot in recovery mode or did you boot normally, with a standard monitor?

If you are on QubesOS 4.1(.1), you should have a grub menu, where you at boot can edit the options for xen and try and add the efi=no-rs and see if it resolves the issue you have with the 4k monitor.

Edit: If it resolves your issue, you can make the change permanent by editing

[dom0]# /etc/default/grub

thanks i had trouble trying to use grub menu but i did manage to edit the grub file but no luck. fyi Im a noob to qubes and linux . I made a screen shot of the grub file. Does the change look ok?

Welcome to Qubes and Linux :slight_smile:

In addition to editing the /etc/default/grub in dom0, you’ll also have to actually update the GRUB config - see:

:slight_smile:

To edit grub at boot time, highlight the boot-profile you wants to use/change, press e and use the arrow keys to navigate to where you’ll add/remove options.When you are done, press ctrl+x to boot.

Thanks, i tried 2 things based on what you said but not sure if I have done them correct, screen shots below. also just tried and what I have done hasn’t worked

Grub edit

From the “Grub edit” image, it doesn’t look like the change was added to the [right] config file.

To test if it changes anything, reboot, press e to edit the grub config and then use the arrow keys to add efi=no-rs to the end of the line that starts multiboot2 /xen-4.14.5.gz ... like:

        multiboot2      /xen-4.14.5.gz placeholder  console=none dom0_mem=min:1024M dom0_mem=max:4096M ucode=scan smt=off gnttab_max_frames=2048 gnttab_max_maptrack_frames=4096 ${xen_rm_opts} efi=no-rs
        echo    'Loading Linux 5.15.76-1.fc32.qubes.x86_64 ...'

Tip: To copy text from a dom0 terminal:

  • highlight the text you wants to copy
  • click Edit → `Copy
  • on the top right, click the “Global Clipboard” and select “Copy dom0 clipboard”
  • in the window where you want to paste the text: ctrl+shift+v and then ctrl+v

Hi Chris , manged to learn the sudo, nano and find commands and found all correct configs I could find and updated, then updated the grub. Still no luck. Considering buy a hdmi upscaler but hoping to avoid as there could be some latency issues. trying to find people on upwork also not that many people experienced in qubes os.

Does it actually freeze with the black screen or can you continue to booting?
I have an older computer with Windows on it, since I upgraded to a 4K monitor the screen stays black until the Windows logon screen. I use full disk encryption, but I can enter my password when the screen is black and it will still boot, though I cannot see anything.
I was thinking it might be a hardware issue that the resolution outputted during boot is to low for the 4K monitor. It’s connected using Displayport but I have a Displayport to HDMI cable with active conversion but that doesn’t work either. An active HDMI upscaler might work though.

Not sure if frozen or not, i cant listen for harddrive as its a ssd and there is no lights for hard drive to let me know if its loading something after it goes to that screen.

Just discovered a kind of work around, if i bought on a normal monitor, then change move hdmi cable to 4k monitor when luks screen comes up it works on the 4k , assuming the resolution is lower.

Just updating this

Bought a HMDI upscaler on ebay, will get around 6th to 8th of December, will update if it worked or not then.

Also have written to Nitro where I bought it , they sell these installed with Qubes so hopefully they will help

Hi Chris, Yeah i can see i had the efi=no-rs in wrong spot from the picture, have fixed it but still no joy. Its in the multiboot2 line after ucode=scan , the same as in the quebes gui troubleshooting guide. Actually is that position ok or should it go right at the end of the line after ${xen_rm_opts}?