Black screen after suspend on Tuxedo BU1506

Hey there!
After some update it crashes the system after suspend mode. If I open the laptop again, I got just black screen and no possibility to do something, but reboot.

Is there some workaround?


What CPU do you have? Are you using S3 suspend mode in BIOS/UEFI? Please provide more information before posting help requests.

Try different kernel versions in dom0. Try to suspend without running qubes (except dom0) for diagnostics purposes.

But in general Qubes OS does not support suspend/resume on most of modern CPUs, even ones that support S3 mode.

i5 7200U

don’t even know what S3 suspend mode is :slight_smile:

Will try to suspend without qubes and with other kernels. Thanks!

If an update caused it to stop working, try older or newer kernels, and see if that fixes anything.

In general, sleep/wake is hard with Qubes/Xen, but most Intel laptops should be able to get it working. Most of the problems (at least on Intel…) seem related to hyperthreading and that Xen disables it - that’s “weird” and tends to put the firmware in unusual states.

If you can disable HT in the firmware, see if that helps anything. However, on a gutless wonder CPU like you have (2C/4T?), leaving it enabled and setting

smt on sched-gran=core

for your Xen command line is worth trying. This tells Xen that it’s allowed to use hyperthreads, but must schedule both hyperthreads on a physical core to the same VM - since anything in a VM is assumed to be able to read anything else in that VM, cross-hyperthread leaks aren’t a violation of the Qubes security assumptions.

I use that on an older laptop of mine, and run with HT enabled, and sleep-resume working properly.

But it’s still a bit more of a coin toss than it should be. :confused:

ok, so I tried the older Kernel in dom0 global settings, without any changes (still blackscreen).
I also tried to suspend without any qubes, but dom0. Still no change.

I will look for it in BIOS.

i5 7200U is 2core with 4threads

I think it’s somewhere in the bootscreen of QubesOS. There I can add this line, isn’t it? Or change off to on.

oh! I just disabled fast boot in BIOS and suspend works!
I hope that the behaviour persists after that, we’ll see.

1 Like

the black screen is back again. But just sometimes as it seems.

By the way, I have suspend mode in the general settings for “laptop lid is closed” (both on battery and plugged in). Should I try hibernate? I suppose it’s even more complicated.

In the system settings, I have hibernate (on battery) and suspend (plugged in).
Maybe the behavior is under hibernate mode and not on suspend mode.

No, hibernate is not supported in Qubes OS.

So meanwhile, I have QubesOS 4.2 and the problem stays.
Sometimes suspend works and sometimes not.
Fast boot is still disabled.
Secure boot is meanwhile enabled.