Black Screen after LUKS

Hey. As the title says I get a black screen after entering my luks password. I have tried adding the efi=no-rs to my grub file at multiboot2 but that just resulted in a boot loop after luks.

I am using an Intel core i7 7th gen and a nvidia geforce gtx 3060. Furthermore I have qubes installed on the laptop directly.

Also I would like to mention that my F2 button lights up when I get the blackscreen. It is the flight-mode button on my laptop.

Any ideas?

Is this a new installation, or were you previously using Qubes OS on this laptop successfully?

If this is your first time using Qubes, note that discrete Nvidia GPUs may require significant troubleshooting.

I tried using qubes before and on first boot everything worked perfectly fine but after that I got stuck in a boot loop. Now, a couple of weeks later I am not even able to boot into the OS although I am using the latest stable version I used before as well.

Okay, try reinstalling Qubes OS and see if the issue persists.

i already did and yes, it does

I do not necessarily know if this also applies to your device, but press F2 when you see your LUKS password prompt to enter into a command-line interface instead. Type in your password, press Enter, and report what the console output spits out back here in this thread.

I took a picture if it and it looks like everything is okay. I even tried connecting a secondary display to make sure there is no resolution issue within qubes.

Okay, try reinstalling Qubes OS without LUKS and see if that allows you to access the login screen instead.

It doesnt. Still the same black screen :frowning:

How about installing Qubes OS 4.2.0 instead?

tried that but stuck in a boot loop with that version

What do you think about getting a community-recommended computer for Qubes OS?

no money sadly but thanks for your help!!

1 Like

If the only thing that doesn’t work is the display output, then the problem could be the display adapter.

GRUB_CMDLINE_LINUX="$GRUB_CMDLINE_LINUX nouveau.modeset=0 rd.driver.blacklist=nouveau video=vesa:off"

You could try disabling the nvidia driver and see if you can boot the system using internal graphics.

1 Like