Black screen after login for approx. 7 minutes

Hello community

I have been using Qubes for many years without problems. However, problems started a on my Acer Nitro 5 around the time when QOS 4.1.1 came out. Some of the updates must have caused problems on my system (slowness, freezing for some time when a qube was started). In order to resolve the problems, I thought a fresh installation of QOS 4.1.1 would fix the problems. However, I was unable to install QOS 4.1.1. During the installation process the screen started to go black and I only got the text installer. I tried several USB sticks, checked hash, etc. Nothing worked. So I gave up on QOS 4.1.1.

Now I reverted back to a fresh install of OQS 4.1.0. This version works fine with my laptop and I was able to use the graphical installer. I loaded the latest templates, updated them and now I have a clean system which is up to date.

However, there is one huge problem. After logging in I am getting a black screen, showing the cursor in the middle of the screen and a tiny grey square in the upper left corner of the screen. After approx 6-7 minutes of waiting I finally get a normal desktop and everything works fine after that. I don’t know what is causing this and I am not really an advanced log file surfer. I was not able to find a resolution for this problem.

Did anybody have the same problem and knows what is causing this?

Thx for any suggestions.

Are you using xfce?

I’m experiencing the same issue with xfce, the time from I enter the login to the desktop is ready just keeps growing.

You can try deleting ~/.cache/* it fixes it for me.

Yes, xfce. The standard Qubes installation.

You mean that after deleting it after a while it starts again?

I will try it.

Yeah, I noticed the problem when it took me 2-3min to load the desktop, then I deleted the files in .cache and it took 15-20 sec.

But the problem slowly returns, now I just delete .cache when I feel like it’s taking too long. Deleting the cache means I need to redo some desktop settings, so I don’t want to delete it every day/week.

Thank you for the suggestion, renehoj.

OK, I just renamed the sub directories in ~/.cache/ to some_old

Now the screen does not go black but I just get the background image of the Qubes OS desktop and only have to wait about 1.5 minutes instead of 7 minutes. This is an improvement of 5.5 minutes but also not very satisfactory. 1.5 minutes is still very long.

So better than nothing but I hope somebody has a real solution for this problem for us so the system works as designed.

Do you also have the Acer Nitro 5?

Really annoying. I am still having the same problem. It takes a long time until I see the desktop after login. Anybody having the same issue?

How many autostart qubes you have?

@enmus :

I have this behavior with standard setup after a fresh installation and not auto generating the personal, vault qubes during the installation.

What journalctl says at the time of login? Does it take usual time (short) to get to the login screen?