Black screen after installation / rescue doesn't work / boot loop after successful installation

Hello there,

I installed Qubes on a Lenovo T530 laptop. Used a usb stick. After the first installation I encountered the error described here:

I tried booting into recovery mode with the method described here:

However, that didn’t work, this is what happens:

Now, I have reinstalled Qubes and did the other option described in the first link, that is I ctrl+alt+f2’d after installation before first restart, then editet xen.cfg:

So far so good, now I have a running Qubes installation. However, booting into recovery mode still doesn’t work.
While booting at this stage the following message pops up:

But as long as all I do is boot and browse, it behaves fine and reboots with only the above message, always the same.

However, after updating, the system no longer boots, instead goes into the following loop:

Recovery mode still doesn’t work, still exact same issue (image above actually taken at this stage).

I’m afraid I’m not a linux person, I have no expertise in this. Getting to edit the cfg in vi was already out of my comfort zone at the time.
Please help.
Can we fix it?

So the main problem is that after updating the system no longer boots.
In order to be able to fix that once it occurs, I would need rescue mode, which doesn’t work. That is the secondary problem.

Btw concerning the Load Kernel Modules error I got this

but I fail to understand what information I should gain from that

So I did the updates one by one, I had a hunch it was the dom0 update that breaks the installation. Unfortunately that is true.
I can update any other qube, but if I want to update dom0 it breaks.

I did it all once again and now it works, no idea what’s different but that’s okay. Now I have an up to date Qubes-OS set up.

At no point did the rescue mode work, unfortunately :frowning: still…

Also what’s still there is the Load Kernel Modules error described above… anyone?