Black screen after install


I’ve tried to install Qubes on my Thinkpad T480s laptop, the install went well but upon first boot I was greeted with a black screen. I looked at the UEFI Troubleshooting guide and found it suggesting to add mapbs=1 and noexitboot=1 to the /mnt/sysimage/boot/efi/EFI/qubes/xen.cfg file, however the file doesn’t exist, I looked in other directories in the /boot partition to no avail.

I was initially trying to install the 4.2.0-rc1 release, however after seeing on the forum the xen.cfg file was removed, I decided to try and older version with the intention of updating it post-install. I tried the Qubes 4.1.0 version, however that also doesn’t seem to have this file and so I’m not really sure how to proceed. I tried to pass them as parameters at Grub to Qubes, but that didn’t seem to do anything, I suspect it doesn’t work like how you pass parameters to Linux.

Any help would be appreciated, I feel a bit stuck.

Hi - and welcome to the forum! :slight_smile:

I guess you’ll have to do without the xen.cfg … it wasn’t part of R4.1 and R4.0 isn’t supported anymore.

You should be able to just hit e to edit the GRUB config on boot (when the option is highlighted) to test adding the options to XEN.

Just to confirm is it the first multiboot2 xen line or the linux (module2) line I should add them to? I have tried both and I was still greeted with a black screen. I have tried doing it to both and still only get a black screen. Maybe something else is the cause, I’m not sure.

You are spot on – multiboot2 is place to add XEN options! :slight_smile:

… but mapbs and noexitboot might be old options for XEN (I couldn’t find them on xen-command-line). :-/

Do you get any debug info, if you remove quiet from the kernel line?

Edit: If you have a NVIDIA GeForce, try adding:


to the kernel line (module2 ..)

Unfortunately I don’t get any info when remove “quiet” and it just has the integrated Intel card, no NVIDIA card. I was looking for reports of anyone installing Qubes on a T480s correctly and came across this post which suggested they had to disable UEFI and go back to legacy booting.

I tried to re-install using legacy booting, however that too installs without problems and then on the first boot it’s just a black screen. I tried removing quiet on the legacy boot and that doesn’t display anything either.

I’m assuming given that test it’s not something related to UEFI bugs but something else which is interesting, although I’m not sure what that something could be.

Also I did have a quick look and I found a reference to mapbs in xen source code but no references to noexitboot.

When you say black screen, do you have the unlocking prompt displayed? Can you get up to a tty or do you have nothing displayed at all after the grub menu?

I do have full disk encryption enabled, and so would expect a prompt to decrypt the disk, but I see no text at all. I see grub and then the screen goes black and remains blank.

I’ve tried installing Qubes without full disk encryption (not an environment I’d ever consider using, but for troubleshooting), hoping that maybe it’d be able to boot into some GUI I’d be able to see something, but without any luck.

I’ve also gone back over the bios options and think everything that needs to be enabled is. Does anyone have any other ideas that might work? Or, does anyone have any ideas to try and get further information that I could use to submit a bug report or debug further?

I have no idea if this could help, but could you try (if possible) connect an external screen and see if something is displayed there?