Black screen after blue 'select operating system' screen

Been trying to boot my laptop for a week now. Its been running fine for over a year but now I just get a black screen after blue ‘select operating system’ screen. Its not even asking me for the disk encryption password. I’ve booted with rescue mode on an installation USB and I can see the partitions. If I input the password I get see all my vm’s. At this point I just want to get the data from 5 vm’s and then reinstall.
What could be wrong?
My guess is I shutdown with a usb attached to a vm or it was a recent update that didnt finish.
How can I get vm’s back?
No recent backup - more fool me.

Try to edit (by pressnig e to the “select operating system”) and remove quiet from the kernel line. That should give more/verbose information about what the machine is doing/trying to do.

1 Like

Seems to be stuck at xen_acpi_processor: Uploading Xen processor PM info

Perhaps this is due to a kernel update that isn’t properly aligned with your current system configuration? AFAIK, Qubes maintains the last 3 available kernels by default.

IIRC, at the “blue screen”, you ought be able to select one of the older/functional kernels to boot with and see where that gets you? With any luck, you’ll be able to login and have the access you seek.

To do so:

  • Before the configured timeout, press the arrow down key to navigate to “Advanced options for Qubes (with Xen hypervisor)” & press enter to choose.


  • Press the arrow down key to navigate to “Xen hypervisor, version 4.x.x.config” & press enter to choose.


  • Arrow down to navigate to the last known good config & press enter to choose.


  • :pray:

If all goes well and, you’re able to boot/login as expected; take a breathe, have a laugh and begin backing up your qubes.

Hoping this helps. :hugs:

I’ve tried all the previous kernels and its the same result - black screen. The current kernel was working until a week ago.

Are you able to provide any additional information/insights such as:

  • Last steps taken.
  • Any changes that may have been made/you were working on?
  • Have you manipulated the BIOS config in anyway (specifically within the context of ACPI)?
  • How old/tired is the system in question?
  • etc.

As the issue seems to be low-level, have you tried to boot from a bootable ISO/USB live distro and dropping to tty while reviewing for any error messages which might help point you in the direction of any hardware faults/issues?

So when it went wrong a week ago it had just done an update (normal gui method) and Dom0 was included in the list. I also had a USB stick attached to a guest for some of that day. I shutdown normally (I think) and the next day had the black screen.
Until today I hadn’t changed anything in the BIOS but tried to changing a few settings ACHI, secure boot etc. Its all back the way it was again now.
It shouldnt be a tired system.
Lenovo P1Gen3 i7 64GB ram 1TB disk - its been great till now.

1 Like