Black boot screen after AMDGPU update with recent graphics card

In January I upgraded my graphics card from a rather old one to an AMD Radeon RX 7900 XTX. QubesOS ran with a very low resolution from that point on. On my Ubuntu system I had to manually install AMDGPU to get 4k resolution, I was not sure if that was the right move for my QubesOS system as well, so I just waited it out. I booted QubesOS a month ago to see if my new graphics card was now supported after applying updates, and Qubes updated the AMDGPU package from version “20230117-146.fc32” to “1:20230625-148.fc32”. Now if I boot Qubes the selection screen for “Qubes with Xen Hypervisor” comes up, but after that step the screen turns black and the monitor stops receiving signals. Is there a way I can revert the update, or get QubesOS to work again in any way?

Can it be the case that you have autostart of some sys-usb qube that has PCI attached. The PCI index changes and the video card as a PCI device gets connected to this qube instead of USB controller and you can blank screen in dom0.
To test this theory you can start Qubes OS with autostart of qubes turned off.

Thank you for taking the time to help me out! I tried your suggestion, but the outcome does not change. I also did not manually configure any qube to auto-start IIRC. For a split second after booting “Qubes with Xen Hypervisor” or through GRUB the following message appears, but I think it also did before exchanging the graphics card: dracut cmdline[314]: warning: USB in dom0 is not restricted. Consider rd.qubes.hide_all_usb or usbcore.authorized_default=0, but setting these in GRUB does not alleviate the graphics problem either.