Bizarre issue with files in vault...SOLVED

Any ideas as to how/why this is happening,

For some reason I am having files that are disappearing or they are deleting themselves in my vault. At first I thought I accidentally deleted them but I have to keep coping them back over from my backup, only to find that again they have (disappeared OR deleted ) some how. My vault is based on “fedora” 38xfce and they are “gedit” files.

Some help please

Where do you keep these files in vault (specific path)?

1 Like

are you sure you didn’t somehow make VAULT or create it as disposable?, it needs to be STANDALONE type QUBE

If anything, if you feel like your vault Qube got compromised because you ran a malicious file there, create a new one based off of the template that’s never been tampered with and make sure you do not run files there, if you ever need to open some PDF, and such, make sure it’s done in a disposable, if you need internet while running that file, make sure it’s a whonix disposable to avoid leaking your personal IP, or at the very least connected to a VPN, plenty of guides here on how to set up a VPN qube, (that’s if you get the file from an non trusted source) generally speaking, make sure that vault does NOT have a net vm set as in it’s offline completely and never give it internet access for your own safety.

No, vault doesn’t need to be a standalone qube. The default setup where it’s an AppVM is best.

In AppVMs (called “Application” in the new “Create Qube” app) only data in /rw is retained across qube restarts, so e.g. your home folder (/home/user) is persistent. Don’t put your data in the root volume if you’re using an AppVM, because it will not persist there.


Could be anything, but if you don’t use any sync tools, you could monitor file deletion.

Maybe it will navigate you to the right direction.

As @B_ryr has not yet answered @Steve question, the rest is idle


Sorry guys, been out “SICK”…

Anyway my vault is just built by the installer when I installed and built my “Qube”. As of yesterday it is still happening “weird”, and even after I copy over and close folder, after a while these “files” just are gone. I have researched as much as I can and did things like…
Open folder “right click” open terminal…type… ls and they are just gone…

Now you guys ready…

SO I left this folder alone, kept on with my work about sometime later, I thought to myself, let me go back in to this folder and they were there. I never copied them back…

I was doing deep dives into find out my problem and I stumbled across these topic…

Linux and the Mysterious case of Vanishing (and Reappearing) directories and files.

Now a lot of you guys have really helped my develop my Linux skills and my Qubes has been a BLESSING.
But this kinda exceeds my skill set right now, they talk about things like…

mkdir sandbox
ls -l snadbox
getfacl sandbox

Another one…

This guys keeps losing All personal files after reboot.

So if I can’t figure this out I may just backup what I can and “delete” my vault" and rebuild it.

Thanks guys for everything

As stated above, if you create files outside the directories /rw or /home (which is contained in /rw), this is not persistent across reboot in an AppVM qube.

1 Like

I found my problem, can this please be fixed???
I do not know if Debian 12 or other templates have this (issue,problem, bug)

You see, no matter whatever file I open, be it gedit, mouse pad, Geany. It obliviously also puts a “LINK” OR SHORTCUT to the actual file in the “Recent” folder, the one right under the "desktop folder.

And when I go into my “Recent” folder and highlight all that I had opened and “Move To Trash”. Well It also either (deletes, moves) the "original files where they are nested, no matter what folder they are in…

That’s the (issue,problem,bug)

I love to run a tight ship in my Qube, can this please be looked into…
I have reproduced this many times tonight with my vault…

Go to “Recent folder” and “Move to Trash” all that you have opened and it deletes the original file, no matter where it is nested…

@Solene, thank you for you time and help…

The “recent” folder in Nautilus file explorer is actually displaying the REAL FILES, not shortcuts or links. So if you delete this, you actually delete the file.

You can try the various solutions here to disable the “recent files”, the thread is old but maybe it’s still working How to disable "recent files" folder in Nautilus? - Ask Ubuntu

1 Like

I’m afraid that this is by design, and is not a bug. (At least,
certainly not a Qubes bug.)
Nautilus is a Gnome application and it is extremely unlikely that
the Gnome devs will change this. (They have strong views that they know
what’s best for their users.)

If you drag an item from “Recent” to the Trash, the actual file will be
moved to the trash.
What you want to do is to Right-Click on the item(s) in Recent, and
select Remove from Recent - this will give you the advantage of
control over the Recent folder, while not deleting the files.

If you want an alternative, the simplest thing is to ignore the “Recent”
folder completely.
If you find the folder intrusive, install and use another file manager -
I’d suggest dolphin, this is part of KDE (another desktop
environment) install it with apt --no-install-recommends dolphin -
it’s a 27MB download for the base application.
Slightly more lightweight is Thunar - if you instal an xfce template,
this is what you will get.
Others you could try are nemo, caja. (There are terminal based managers
like nnn, but I’m guessing that would be a step too far. Some people do
without managers completely.)

The beauty of Qubes is that it’s simple for you to test these out
without commitment.
Clone the template to Debian-managers, install all the managers you want
to test in to Debian-managers, and change your work qubes to use that
This will give you a chance to try out alternatives.
Once you have decided on one, you can install it in to your base
template, change your qubes to use that template, and delete


(Nevermind–decided this was the wrong place for this comment.)

Oh, it’s definitely a bug…but the bug resides on the other side of the keyboard interface with the gnome developers.

Why have one file show up in two places, in such a way that deleting one deletes both?

Worse, why does this paradigm-breaking folder (which is a lot like micro$aft’s craptastic pseudofolders) have to be the one chosen by default in Nautilus? (An appropriate name as it should be deep-sixed.)

Gnome, in fact, sounds like they have the micro$haft arrogance…maybe miacro$haft owns them?

A good file manager negates any need for a desktop on that VM, IMHO, but Nautilus isn’t it. (I only just realized that some people actually run desktops on their domUs.)

Thank you guys for your input.

I am wondering their a way to disable “recent” folder"? As I have no real need for it but yet like Thunar.

I will be using @unman suggestion…
" What you want to do is to Right-Click on the item(s) in Recent, and
select Remove from Recent - this will give you the advantage of
control over the Recent folder, while not deleting the files."

Well,Well,Well…ask and you shall receive…I’m not the only one… obliviously

Have not tried yet but I am going to…

Thunar “Recent Folder” WORK AROUND…

Link #1 (Read first)

Then at bottom of post there is a Link…Here

Do this edit by (jrichard326)…

The following worked for me:
Put the following in ~/.config/gtk-3.0/settings.ini (create the file if it doesn’t exist):


Then, remove the file holding recently-used data:
rm ~/.local/share/recently-used.xbel

The recently-used.xbel file got recreated after deletion with this content:

<?xml version="1.0" encoding="UTF-8"?>

<xbel version=“1.0”

And then this post also talks about “permanently disabling ”

I love my “Linux Buddies”


That’s odd.

I use Thunar exclusively and do not have “Recent” showing up. Otherwise I’d hate it. I’m pretty sure I didn’t disable it. I never had it.

How is this usable without KDE environment/recommended packages?

All Places are showing up by default for me.

Well I found what “worked” for Thunar… Tested and working

-Have to do it in the domain as it didn’t apply from the template
-Open terminal and do the following…

sudo rm ~/.local/share/recently-used.xbel
sudo touch ~/.local/share/recently-used.xbel
sudo chattr +i ~/.local/share/recently-used.xbel

Shut down and restart domain

Then remove “recent folder” from places.

1 Like