Bitrot, suspend, fedora-36, firefox

Recently, my Intel Nuc10 based system I have been running for quite some time now has stopped suspending. Well, it suspends, but it never resumes.
Prior to this, I have been able to either explicitly suspend (power button, or menu item) or let it decide to automatically. Zero resume issues. Recently, 100% broken. If it suspends, it will not resume. Suspend/resume was 100% reliable. Now it is totally not.

Since a month or so ago, I find that I can be using Firefox in a fc-36-based VM, and after a while, switching between TABs stops working. IE: I click on the TAB in FireFox and nothing happens. It seems the entire FireFox is frozen, but if I diddle about with other windows, or resize the FireFox window, it “wakes up” again. I thought it was an issue of memory bloat and paging, but I increased the memory to certain AppVMs and have been watching the memory (via top and also some Firefox internal process listing) and I see no evidence of bloat, plus zero paging to swap. Happens when I have multiple windows open with multiple TABs and also when I have just one window and a few TABs. Not 100% sure, but it is not isolated to one particular VM.

Prior to the recent FireFox freeze (which I sort of think is X server related) I used to frequently have old window partial contents left on the screen. Like the X server did not process all the exposure events properly. Moving some window thru the non-redrawn area would, natch, fix it.

Anyone else seeing anything like this?

My system is fully up-to-date and sufficiently rebooted.

Being paranoid, I wonder: Have I been hacked? Is there a RAT running? Due to both of the above issues, I reboot (full system) and restart (individual AppVMs) frequently, but whatever the issues are, they come back.

Which memory? Where did you run top?

When you have a seemingly frozen window, have you tried running a command into it from dom0?

qvm-run -p disp-1234 top

I usually have terminal windows running in all the suspect AppVMs with top running.
Typically, I have selected top options to display memory and swap usage.

I also have a FireFox window open with about:processes (or whatever it is) showing processes.

I have also clicked on the icon at the upper right menu bar which shows the CPU and memory usage of the VMs.

I have also used xl top in dom0. These days, I am not thinking it is memory related. Recently, based on further observations (ie: that I can cause exposure/redraw events to clear things up) I think it is more likely to be X server issues. But I still do monitor memory and swap usage, as it is in my DNA.

When the FireFox window gets constipated, the other windows (Terminal, emacs, …) are all OK, but I will try the command you suggest next time it happens.

What kernel are the vms using?

$ qvm-prefs $vm-name kernel

Just tried that on a few AppVM. I either get:
TERM environment variable not set
– or –
top: failed tty get.

What does seem to work is:
qvm-run -p VM -- top -b -n1 | less