Auto start VPN issue

Hello,

I am trying to run automatically openvpn in the same solution like this documentation: Contents/vpn.md at master · Qubes-Community/Contents · GitHub

After rebooting it doesn’t work. Only if I run this script manually then getting the VPN correctly.
vim /rw/config/rc.local
chmod +x /rw/config/rc.local

# Automatically connect to the VPN once Internet is up
while ! ping -c 1 -W 1 1.1.1.1; do
   sleep 1
done
PWDFILE="/rw/config/NM-system-connections/secrets/passwd-file.txt"
nmcli connection up file-vpn-conn passwd-file $PWDFILE

Do you know how can I solve this issue?

or you can try with enabling systemd rc-local.service

This post was flagged by the community and is temporarily hidden.

Do you mean sudo systemctl enable rc-local?

[test@proxy-vm-temp config]$ sudo systemctl enable rc-local
The unit files have no installation config (WantedBy=, RequiredBy=, Also=,
Alias= settings in the [Install] section, and DefaultInstance= for template
units). This means they are not meant to be enabled using systemctl.
 
Possible reasons for having this kind of units are:
• A unit may be statically enabled by being symlinked from another unit's
  .wants/ or .requires/ directory.
• A unit's purpose may be to act as a helper for some other unit which has
  a requirement dependency on it.
• A unit may be started when needed via activation (socket, path, timer,
  D-Bus, udev, scripted systemctl call, ...).
• In case of template units, the unit is meant to be enabled with some
  instance name specified.

sudo systemctl enable rc-local.service

The output is the same