Audio stuttering

If I attempt to watch any video online or listen to any audio only files online there is extreme stuttering. I have tried qubes based on both Fedora and Debian as well as different browsers in each of these qubes. It does not appear to make a difference. I have also turned off hardware acceleration in these browsers which made no change. Other than the 2 qubes made to test different browsers, I have not made any changes to the settings of the OS.
Youtube is the worst, the stuttering in it is machine gun like and to the point it sounds like it has heavy reverb. 1080p and above are worse but even at 144p it persists.
It seems odd but in an anon-whonix qube with multiple tabs open I do not have this issue regardless what quality I select for videos. For this reason I do not think it is hardware related.
Qubes 4.1.1
i5-10400 processor
1TB NVMe M.2 SSD
32GB RAM
Any help in what I may need to look at or change is much appreciated.

No changes made to anything, but today I cannot reproduce the issue. As I type this, I have multiple qubes running, and in them multiple browsers running. All are able to play videos and or audio files perfectly, even at qualities higher than 1080p. This leads me to believe it is not an OS issue, except that other devices connected to the same network but with different OS did not experience the issue when this PC did.
I understand Qubes does not use the processor the same as other OS but I do not understand why the issue I am experiencing appears to be intermittent. I also do not understand why anon-whonix qubes were unaffected when experiencing the issue.
I do not see anything unusual in traffic to explain the issue either.

I have not been using this PC much since my last post. In the last several days though I have tried to figure out what is causing the issue. During this time I have noticed that there is also mouse lag/stutter as well, even when not attempting to view video or use audio. At least once with a single tab open in a browser checking an email account. It gets worse with multiple tabs open or viewing websites with lots of images.
Thinking that it may be a RAM or VCPU issue, I attempted to change values for these under advanced settings for qubes in the Qube Manager. This did nothing but create a new problem. I could not open any of my qubes after doing this and got an error message stating failed to start: internal error: libxenlight failed to create new domain. This error message would include the name of any of the individual qubes I attempted to open.
I reset all qubes to the default values for RAM and VCPU and restarted the PC. This at least got things back to where I could open all the qubes. I do not know why this happened as I did not set the values to anything extreme, perhaps that is not the right way to change those settings.
Using xentop while experiencing the lag/stutter issue, I see no sign of a RAM issue but the CPU% for the qube will be as high as 200%. It will also switch state between running and blocked even when not experiencing the issue. I see the same behavior regardless of what qube or browser I use.

Have you tried upgrading to the 6.x kernel?

I might also be worth checking Xorg.0.log for any warnings or errors, and making sure you are using the correct driver for your hardware.

1 Like

Thank you for your reply and suggestions. I have wondered about drivers since installing Qubes, as to how to update them or if it was needed. I have searched some on the subject and most of what I found mentioned that they are updated or included with the kernel. I will look into that further though but the only things I have seen so far that mention needing to update them were regarding the use of Nvidia GPUs or other things I am not using.
I have not looked at any logs yet, one error message I was getting did mention a log to check but when I attempted to view it, I got a permission denied message in the terminal. The log mentioned in the error message was /var/log/libvirt/libxl/libxl-driver.log
I am completely new to Qubes as well as Linux and I need to look up how to access different logs including the Xorg.0.log. I will try to do that today.
I have seen multiple threads or posts that discuss kernel latest being a possible fix for multiple issues. I believe I know how to do the update but have been concerned about whether it may cause other problems and if I would be able to roll back if needed. I will try this and if things go wrong at least I have a Qubes ISO on USB if needed for reinstall.

The old kernel isn’t automatically deleted, if you are unable to boot after updating to a new kernel you can always revert to using the old kernel.

The new kernel will automatically be selected when you boot, but you can manually select an older kernel you know is working. At the blue grub boot screen with the 5 sec delay, you can use the advanced menu to select older kernels.

1 Like

Thanks for the information on that. I’m currently reading up on some log stuff, I haven’t accessed the xorg one yet but do see some things in the logs from Qube Manager I’m going over.

OK, so I was able to run the sudo qubes-dom0-update kernel-latest in Dom0 terminal. Using uname -r after reboot shows it worked and is now using 6.1.12-1 kernel. At the moment audio and video are working great in all qubes I have tried. I will check it some more over the next day or so, but believe that fixed those issues. I am still having extreme lag/stutter with the mouse when visiting some websites, it does not appear to be as choppy as before though.
I have not found out how to check drivers in Qubes yet but I’m still searching. I also have not been able to find out how to view or access the Xorg.0.log
I see instructions for Linux distros, just haven’t found it for Qubes yet. If the audio/video still works fine after some more testing, I will mark your reply about the kernel as the solution.

The system logs are in the directory /var/log, Xorg.0.log is also in that directory.

I see it in Dom0 File Manager but do not have a way of opening it there. Can I use the qvm-copy-to-vm to access the file? I am probably doing it wrong but when I tried accessing it by bash, I get permission denied.

Yes, qvm-copy-to-vm works, but you can also open it vim /var/log/Xorg.0.log

1 Like

Thanks, I will try that.

Well, I spoke too soon. It’s back to the original behavior for audio/video at the moment. I was able to look over the Xorg.0.log after your help yesterday. There were two things I saw mentioning the mouse and keyboard stating “No input driver specified, ignoring this device.” and one mentioning mouse acceleration factor and threshold.
I don’t know if these affect the audio/video situation but may explain the mouse behavior.
Something else I saw in an individual qubes log was “You have booted with nomodeset. This means your GPU drivers are DISABLED”.

It’s only dom0 that has access to the display device, you don’t need to worry about the qubes.

Which display driver gets loaded in Xorg.0.log?

I see a video driver listed twice. X.Org Video Driver, version 24.0 and several entries below that is version 24.1 if that is what we are after.

Try generating a xorg.conf with this command X :1 -configure it should make a file called xorg.conf.new, what does the driver tag in that file say?

I’m not sure I did that right. I entered the X :1 -configure and when I hit enter, it started to do something but then the PC crashed or went to the black screen I normally see briefly between the PC BIOS option screen and the Qubes blue screen at startup and just stayed there. I pulled the power cable and restarted.

I might have typed it wrong, the second time worked ok. At the end of it running, it shows this error.
Your xorg.conf file is /root/xorg.conf.new
To test the server, run ‘X -config /root/xorg.conf.new’
(EE) Server terminated with error (2). Closing log file.

I haven’t looked at the xorg.conf.new file yet.

Being that the xorg.conf.new file is a root file, I had a hard time finding out how to access it. After hours of searching and reading, I found out how to get root access in the terminal but the only thing that I found to work opening it was the vim you mentioned previously. I don’t know if that is how I should have done it but it did open it.
I do not see any driver tag though. For keyboard driver it just says “kbd”, Mouse says “mouse”, and there is a section that just says “Device” that shows driver as “intel”.

In the terminal you can start a command with sudo and you will run it as root.

Trying copying the file to /etc/X11 and rename it to xorg.conf

You can use the command sudo cp xorg.conf.new /etc/X11/xorg.conf

When you reboot, if the system isn’t able to load the x server you need to delete xorg.conf from /etc/X11

1 Like