Audio no longer works at all in dom0 and VMs after upgrading to 4.2

Hello, all. I saw two forum posts related to this:

but the first one suggests uninstalling pipewire from dom0 (which seems to remove one of the key upgrades of version 4.2): Audio not work in appVM on 4.2.0-rc1

And the second one, I followed the instructions and they did not succeed for me:

Basically, everything is working great after the upgrade to 4.2 except that now my sound doesn’t play in any template nor in dom0. I tried my old templates that I upgraded, but also downloaded the new templates that already have pulseaudio-pipewire installed, and no luck.

In fact, at the moment my internal speakers are not being recognized in Pulse Audio Manager at all, so it doesn’t see the playback device. Can anyone assist? Is this something that the upgrade failed to switch?

About pipewire in dom0 - is not supported in dom0, only in other qubes.
Source: Pipewire audio support · Issue #6358 · QubesOS/qubes-issues · GitHub

Not sure, but after I’ve set the audiovm to dom0 (this is the default value for 4.2-RC3 deployments), I got sound…

qvm-prefs $qube audiovm dom0

Thank you @balko for linking that post; it is very helpful. Thank you @solene for your suggestion; that seems to fix my problem for now at least. :slight_smile:

I just ran the line you suggested in the dom0 terminal and replaced “$qube” with the VM I was trying to get sound from. Oddly, I only did this once for a single VM and now all my VM sounds seem to be working…


Just discovered this topic, as I hadn’t realized that since I upgraded to 4.2.0-rc3, I have no sound any more, in any qube. Everything looks fine, except I have no sound.

I’ve tried @solene 's fix :

that did not work for me (the same for @moonlitOrca 's version, to me that was with “personal” qube, did not work either).

Where should I search first ?

I actually just today started having that same problem again. I wonder if this should be filed as a bug report in github because the upgrade script seems not to have successfully done whatever is needed to switch the audio system successfully. I will keep playing with it to see if I find anything out, but I don’t know pipewire very well at all.

In my case I didn’t know about PipeWire, just discovering it as it begins to be shipped by default in major distros.
I’m with debian 11 by default, and have /usr/bin/pulseaudio and /usr/bin/pipewire running processes in dom0, so eventually I don’t know which one is used.
I also noticed I couldn’t play any video from the internet (youtube, news broadcasting channels, etc), the video never starts.
Maybe is it related to nvidia driver I tried (unsuccessfully) to install previously (to try to fix a resume problem).
As this is a test machine, I’m trying wiping and clean installing 4.2, just to get rid of any nvidia driver interference, I’ll give a feedback.

Just to let you know that in the end, I didn’t need to clean install to remove any junk with nvidia, just removing pipewire from dom0 with dnf remove pipewire was enough, like @uuqz188 did in Audio not work in appVM on 4.2.0-rc1, it worked for me, the sound is back in VLC or firefox in any AppVM. :slight_smile:

Thanks so much for taking the time to come back and let us know how it went. Is removing pipewire from dom0 recommended? I just want to be sure I don’t break anything. I thought dom0 was acting as the audioVM? If anyone here knows better than I do, please clarify the relationship. I can’t seem to find documentation on pipewire yet in qubes.

If the problem continues, I will give it a try :slight_smile:

I don’t have enough skill to tell things apart regarding dom0 acting as the audioVM, not even with pipewire nor pulseaudio, but except from my tests regarding attempt to install nvidia driver (which failed), my installation is rather ‘by default’, and removing pipewire in dom0 seems to allow pulseaudio to act normally (I just checked before removing that both were present in dom0 by default).
So yes, if anybody has a bit of knowledge (maybe does it also work by removing pulseaudio rather than pipewire ? ) to clarify, it would be very helpful.

Good luck :slight_smile:

Revisit the link with some answers of @Demi about pipewire status. She says that pipewire in dom0 is NOT supported. So you probably should not have installed it in the first place.

Thanks for adding to the conversation. I read through the pipewire thread there you linked, and I very much look forward to getting some more clarity on how this works.

I think that no one actually added pipewire to dom0; I certianly didn’t. So if it must be removed for sound to work correctly, then that would seem to be an important error in the in-place upgrade script. I have a bug report open for this: No sound playback devices available after in-place upgrade to 4.2 · Issue #8560 · QubesOS/qubes-issues · GitHub , but it still doesn’t seem clear exactly why the upgrade broke the system. What’s even more strange is that, whenever I boot, sound works sometimes but doesn’t on other boots. Very odd.

1 Like

And audio is back.
I backed up my qubes
installed 4.2.0
restored my qubes
Then opened my Debian template
sudo aptitude install pipewire-pulse
And all of my qubes which use that template have audio again