Áudio em máquinas virtuais standalone: uma solução deselegante (mas funciona)

Oi gente. Beleza? Eu tava passando por umas treta com uma HVM com Manjaro Linux que eu tinha feito, e agora que deu certo eu queria passar a minha solução pra vocês. Não tava saindo som.

Eu descobri (aqui: Audio Virtualization | Qubes OS) que as máquinas virtuais do Qubes por padrão mandam o áudio pra dom0 usando um canal virtual antes de mandar pro hardware, mas como sistemas operacionais externos não tem esse canal virtual já configurado, então a VM não sabe pra onde mandar o som.

Uma solução meio deselegante que eu encontrei foi mandar o áudio direto para o hardware, em vez da dom0. Fiz isso usando só interface gráfica mesmo.

Pra mim foi:

1- Abrir o Qube Settings da minha VM
2- Ir pra aba Devices
3- Colocar a minha placa de áudio na minha máquina virtual

Não sei se vou conseguir ajudar alguém com isso, mas funcionou pra mim. Espero que seja útil pra mais alguém.

-Veio do Café

2 Likes

Uma observação: por algum motivo, depois de bootar o Qubes eu tive que esperar uns 3 minutos antes ligar a máquina virtual pro áudio funcionar. Não sei bem o por quê, mas tá aí…