Asus Zephyrus GA402RJ Fan Speed

I can’t seem to get the fans spinning fast enough. They don’t even come on until about 70C and then only about 10% at 80C where I think it starts thermal throttling. The required kernel modules that I need have been removed for security reasons. I’m about to cut the blue wires to the CPU fans to kick them up to 100% but I know this is a bad idea, so can anyone please help?

Here’s a link to my machine on the HCL for hardware specs:

Thanks in advance.

Not sure if you’ll be able to fix this in Qubes 4.1.2 since it use Fedora 32 in dom0, but maybe you can try:
ASUS NoteBook Linux
But it should work in Qubes 4.2 because it use Fedora 37 in dom0.

Yeah, that would be the ideal solution. The instructions from here:

for fedora say to run:

$ dnf copr enable lukenukem/asus-linux
$ dnf install asusctl --refresh

which works on bare metal (fedora38) but allowing copr repos is not an option for dom0 as far as I can tell, so I’ve been trying to compile from source from here instead:

I completed all the prerequisites:

  • updated the dom0 kernel
  • installed rust >= 1.57
  • installed cmake clang-devel systemd-devel glib2-devel cairo-devel atkmm-devel pangomm-devel gdk-pixbuf2-devel gtk3-devel libappindicator-gtk3

but make fails when I try to compile because dom0 has no internet:

[wahcha@dom0 asusctl-main]$ make
cargo build --release
info: syncing channel updates for '1.65.0-x86_64-unknown-linux-gnu'
error: could not download file from '' to '/home/wahcha/.rustup/tmp/7aj05hr7on6fyvbf_file' failed to make network request
make: *** [Makefile:118: build] Error 1
[wahcha@dom0 asusctl-main]$

How can I work around this?

Can’t you build it in fedora-32 appvm and then transfer files to dom0?

That almost worked. I ran make on an appvm:

[user@appvm asusctl-main]$ make

and then transfered over to dom0 and ran the installer:

[wahcha@dom0 asusctl-main]$ sudo make install

which completed successfully, but asusctl failed to launch because glibc was missing:

[wahcha@dom0 ~]$ asusctl
asusctl: /lib64/ version `GLIBC_2.33' not found (required by asusctl)
asusctl: /lib64/ version `GLIBC_2.32' not found (required by asusctl)
asusctl: /lib64/ version `GLIBC_2.34' not found (required by asusctl)
[wahcha@dom0 ~]$ 

so I installed glibc, but that only gave me version 2.31 and asusctl needs 2.32 or better:

[wahcha@dom0 ~]$ sudo qubes-dom0-update

 Package         Architecture   Version
 glibc           i686           2.31-6.fc32

I tried manually installing a more recent version of glibc, but got bogged down in unresolved dependencies.

@disp6252 You mentioned that Qubes 4.2 will ship with Fedora37 in dom0. That would have a more recent version of glibc in its repos. Where can I find an upstream release of Qubes 4.2 to try?

Did you built asusctl in appvm based on fedora-32 template? The latest version of glibc in fedora-32 is 2.31-6.

I built it in and appvm based on the Fedora 37 template. The problem is that I need glibc 2.32 on dom0 to run it. The dom0 repos only have 2.31. That’s why I’m trying on a weekly build of 4.2 now.

The weekly build download link kept failing, so I tried again using the stable release of Qubes. This time I installed to a Fedora37 appvm via the copr repo and copied /usr/bin/asusctl to /usr/bin/ on dom0. That didn’t work either. I’m getting the same errors as before:

[wahcha@dom0 ~]$ asusctl
asusctl: /lib64/ version `GLIBC_2.33' not found (required by asusctl)
asusctl: /lib64/ version `GLIBC_2.32' not found (required by asusctl)
asusctl: /lib64/ version `GLIBC_2.34' not found (required by asusctl)
[wahcha@dom0 ~]$ 

I know the answer is to install to an appvm and transfer to dom0 but I can’t get that work. Can I control the CPU/GPU fans with Xen instead?

So, I tried on Qubes 4.2 and actually got rog-control-center to launch and control the keyboard backlight but not the fans. Most of the solutions I’ve found rely on the asus_nb_wmi and/or asus-wmi kernel module(s) which have apparently been deliberately omitted for security reasons.

See marmarek’s comment here about PCI hotplug and DMA attacks:

Is there any practical way to add the asus_nb_wmi driver to dom0?

Nvrmind. I just cut the blue wires to the CPU and GPU fans. Rather have them stuck on 100% than 5%