Asus Zenbook 13 keyboard backlight not working. Possible solution found, but help needed

I have a problem with my keyboard backlight not working on my Zenbook 13.
Backlight works on all live usbs I have tried also on windows.
After Investigating a bit about my problem I have maybe found a fix. If so simple fix is possible really.

So because of lack of my deep Linux knowledge maybe someone can help me solve this.

I have discovered that in a folder /sys/class/led/
One folder is missing from my qubes device.
But it is present on live boots from different Linux Isos via USB. By my understanding in “led” folder are all controls for led lights on the device.

This missing folder is called /sys/class/led/asus::kbd_backlight

On the pictures you can see on a live usb (left pic) there is the folder but on my setup (right) there is none.

I have tried to copy the folder from live usb but can’t, and I can’t modify in my dom0 /sys/class/led/ files at all. Tried to add permission but failed.

Could it be that only this folder can solve the case?

Am I in the wrong subforum, why is nobody responding?
Should I repost in "user support "?

I have no knowledge about backlights, but from the pictures above it can be seen that those are links to files. So, you have to check where it leads to, I guess…

1 Like

Yea they are shortcuts.
I have found this folder in real place.
But it is full of more and more shortcuts. Some of them in a loop returning you to the same place.
Folders of shortcut full of folders of shortcuts.
Can’t seem to think of any way to replicate or copy this files

For what I have discovered googling it’s a kernel thing. Is it there any way to add this to current kernel or copy from the original one. Or something that I can do. I really like this laptop. It would be a shame if I couldn’t resolve this. It is difficult to type in the dark without the backlight