ASUS BIOS update breaks my Qubes OS

After the BIOS update (to 2022/05/12-v3802), I lost opportunity to continue using Qubes OS.

My, a year ago installed vanilla Qubes OS, is still well booted to dom0, I can create an remove AppVMs, but I can’t start an AppVMs : because dom0’s PS/2 keyboard and a mouse stops working, the clock on the dom0 XFCE panel is working, dom0 terminals are delayed.

The Qubes OS live USB is not working, so I can’t reinstall the system as I do that before. I’ve already tried my early used for installation USB with v4.1.0 and a new one with v4.1.1 - the same result.

So, my dom0 is working perfectly, AppVMs and live USB are not working. (BIOS downgrade is blocked by the vendor :sweat_smile: ) The BIOS is in it’s default settings state, IOMMU and SVM Mode (CPU Virtualisation) are enabled.

Please, suggest ways to solve the problem. What are the BIOS settings I should try to change?

  • What is the model of the computer?
  • How did you install Qubes OS? (thin lvm/btrfs, legacy/uefi)
  • Are you using a SSD or a hard disk drive?
  • This is the Asus b450m-csm motherboard with Ryzen 7 pro 3700, Kingston ECC memory
  • This is thin lvm Qubes OS installation. Installed via USB live
  • I use SSD (2,5 inch), mdadm 1 raid.

What happens when you get rid of the raid?

Obviously the right thing to do is to figure out what the incompatilibyt is so the community can help resolve it.

But if you are 100% sure this is down to the BIOS flash and you cannot wait for that to happen in order to get back in again, you could download an old version of the BIOS and use a programmer with a SOIC clip to downgrade to the version you had. While the manufacturer prevents downgrade via the internal programmer you can use external flasher to downgrade just fine. Make sure to check the version of the chip and that your programmer uses the right voltage for that chip.

You can find all of the old BIOS files here (click ‘see all downloads’ to find the one you want)

The BIOS files come in a ZIP file and will contain a .CAP file. This CAP needs to be converted to discard the top 2048 bytes and then you have a ROM file that the GNU program ‘flashrom’ can use

dd if=PRIME-B450M-A-ASUS-XXXX.CAP of=PRIME-B450M-A-ASUS-XXXX.rom bs=1024 skip=2

Obviously replace XXXX with the version.

The BIOS rom is this chip next to the battery - is blurry but looks like a winbond.

than you just connect up the SOIC clip and programmer using a different machine, run flashrom and then thats it downgraded. Its also worth backing up the ROM thats on there too just incase.

flashrom --programmer <YOUR PROGRAMMER TYPE> -r read-asus.rom

flashrom --programmer <YOUR PROGRAMMER TYPE> -w PRIME-B450M-A-ASUS-XXXX.rom

obv., consider this like a last resort if all else here fails.

1 Like

second thread - has the drive controller mode changed?

Also I find on some ASUS devices the Live USB has weird video corruption, but its the loader. Just wait 60 seconds and see if the installer starts up.

Nothing happens. I’ve plug off all SSD with no live USB boot result.

SATA always in AHCI mode.

I’ve been waiting for more than five minutes, I’ll try again.

I’ve set up a spare same model motherboard with my old BIOS v2202 and problem disappeared on its own. My Qubes is back :slightly_smiling_face:

I’m sure, that’s the last BIOS version that was a problem.