Archlinux template builds but won't run

I successfully built Archlinux template following the instructions from, except that 4.0 failed to build so I tried again with 4.1 current-testing.

This produced a .rpm which I transferred to dom0 and installed manually using dnf, since the file “” was not created in the parent folder of the .rpm, as described in the tutorial. When I look at the new archlinux template Applications list in the Qube Manager, I see no programs listed, and when I click “Refresh Applications”, a dialog appears that says “Command '[‘qvm-sync-appmenus’, ‘archlinux’] returned non-zero exit status 1.” I also see a system notification that says “qrexec-daemon startup failed: Connection to the VM failed.” I tried changing the template to run in HVM mode, and it boots successfully, logging in automatically as User.

Is the missing “” the culprit here? Or did I miss some other step?

I’ve fetched the latest qubes-builder (466aa0 from Dec 31), and ran the build again, but the script qubes-src/linux-template-builder/rpm/ described in the tutorial is still missing.

The issue is a bug in the builder0 but that has no bearing on the template functionality. It is just a convenience script to pull the built template rpm into dom0; you can do that manually with qvm-run. Are you not able to get past the issue?

As I said in the first post, I was able to copy the rpm manually, but the template, once copied to dom0 and installed, is not usable.