AppVM Qube won't open after updating sudo upgrade

After updating using “sudo apt upgrade” , the Qube restarts and won’t start back up. It takes very long and then doesn’t start. I did some research and seen that the qube doesn’t have enough space. I tried making the System storage max size larger but it still doesn’t seem to give the qube the space it needs.

Are you able to start and run the template on this this is based?

Did you also try to increase the private storage size? (Sorry for the stupid question, but it did happen with me once.)

I can run templates fine, but there is software within the VM that needs to be updated. So when I update the software, i guess it also updates the entire VM. Then the VM doesn’t open. It juts says “starting…” and stalls. I’m assuming that’s because there isn’t enough space.

Yeah, I’ve tried increasing both.

I fixed it, how can I delete this thread

You don’t delete it, but in order to help others you write how you fixed it.

1 Like

Yeah, for sure. I ended up realizing that my Debian had reached EOL and my Qubes was out of date as well. So I upgraded to the latest Qubes via fresh install. And updated my templates, etc. when I reloaded the backed up Qubes, everything updated and worked fine.

1 Like

Thanks, I find this is valuable info, since many would try to use EOLs.