AppImage added to Application List but won't execute program

I downloaded an AppImage, made it executable with “chmod +x”, and I’ve been able to create a .desktop file. I’ve added the file into /usr/share/applications/, along with the AppImage in there too. I’ve also updated and synced the AppMenus in Dom0. Next, I shutdown the TemplateVM and booted up the AppVM. The software shows in the startapp menu list but when I click it, nothing happens.

Here is the .desktop file:

[Desktop Entry]
Comment=File Encryption

it could be FUSE related issue, since i have it too. but try runing it via the terminal and see what you get in response.

1 Like

Do you get an error if you start the app from the command line?

No errors. The AppImages start fine if I double click them or run from terminal. I just to know how can I get them to execute after being added to the VM’s Application List

Open a terminal in the vm and check if the full path launches the app:

$ /usr/share/applications/Picocrypt.AppImage

Yeah, just tried and it runs

It finally started working! I guess I had to restart the entire PC and not only the TemplateVM and App VM. It works now. Thanks

1 Like