App Will Run in Debian Template, Won't Run Outside Template

I installed an application in the Debian template using sudo install apt applicationname.deb.

I then shut down Debian 10 (and all other Debian templates). I rebooted Debian 10. Then I shut it down again.

The application shows up in the Debian 10 template Application list.

I created a new AppVM template for Debian just for this app. I found the application in the list inside the Qube settings for this AppVM and added the application. Then I ran the application. Nothing happened. The AppVM qube starts, but the application never opens.

I then started the application using the Debian 10 template (which is really not smart, but I wanted to see if it would run). It did run. The settings in both qubes are exactly the same. The Debian 10 Qube just for the app has the same memory, internet, everything.

Any ideas about what’s going on here?

Can you run manually in appvm?

Maybe you can try read this :

1 Like

try opening a terminal in the Qube that uses the template, and run the app from the command line (perhaps with any debug/verbose switch)

One possible explanation is that the Debian package uses some part of
the file system that isn’t inherited by the qubes. You should be able to
see this if you try to start it from the command line.
You can read here
about how the qubes inherit from the template.

You can always revert the state of the template to a previous one before running (if you did not reboot twice): Volume Backup and Revert | Qubes OS

The shortcut is there. It’s not that there is no shortcut.

I am so n00b that I don’t even know where the f*ck the app is. I see it in the menu, but when I do a search in the qube file system at the highest directory level, I only see a program link, and a program icon, and some other stuff. All of the file sizes are small, with the largest one being the icon image. I do see the name of the app with a .desktop attached to it, but is that it? I’m not sure of the command I would use to run it in a terminal. I know sudo… apt? install? cd? Are there other commands?

I feel like I’m in way over my head. I really wanted to get rid of Microsoft Windows after a bad experience. I am not a lesbian, but I was curious about… what they do. Afterwards, Bing started marketing various gloves and scented oils to me. It was probably a coincidence, but the whole thing made me uncomfortable. I thought I had been so slick, using incognito mode and clearing the history another time. Then I read more about Windows and was horrified. I am f*cking done with Windows.

I decided if I was going to unchain myself from Microsoft, I may as well go all in. And before you say it, no, I don’t want to f*cking learn Mint. I am learning Qubes, if I am learning Linux, I will figure out Qubes or destroy myself through insomnia in the process.

Should I just copy a bunch of random folders over to the AppVM and hope it works?

Also, my Debian template and AppVM now have two “Run Terminal” programs, so there’s that too…

1 Like

I have no idea what a debug or verbose switch. I’m literally probably the dumbest person on this forum. Which means I’m still smarter than most people, but dumb as hell for here.

Also, I ran the app in my Debian template to see if it would run (and it did). Did I ruin my Debian template?

Thank you for your suggestions. One day, I will be the Princess Warrior of Qubes instead of the n00b who can’t figure out how to run an application.

Let’s start at the beginning - what is the package you have installed?

1 Like

Zoiper5

You sure made my day :rofl:
What command you issued in debian template? Ex if it’s n00b

qvm-run --dispvm=n00b(< change this n00b to your debian templatevm name) --service qubes.StartApp+n00b

I don’t understand.

How would I start the application in the AppVM if there’s no mention of the application that’s in the AppVM?

So if the AppVM is called “QubesVMDebian1” I would type:

qvm-run --dispvm=QubesVMDebian1 --service qubes.StartApp+QubesVMDebian1

?

I’m not sure what this would do. Do I type this in my Terminal? In the Dom0 terminal?

Should I click the first “Run Terminal” program that is now listed in all Debian templates or the second “Run Terminal” program that is now listed in all Debian templates?

I don’t know what to do.

From dom0, not appvm name, fill it with your debian template name.

Refusing to create DispVM out of this AppVM, because the template_for_dispvms=Fase

Type Zoiper --help from your terminal appvm.

bash: Zoiper: command not found

Try again in your appvm terminal zoiper --help if it’s still not found, try both in your debian templatevm terminal.

Still nothing.

The name of the actual .deb package was a lot longer. Do you want the full name? It’s got a lot of x64 and version number stuff in it I think?

hey everyone starts somewhere. You got a bunch of stuff done on your own and are reaching out for help with things you are stuck with. Hardly dumb, to me.

OK so sounds like a source build which has been packaged up. You can find out which files have been installed by using dpkg. Do this in your template first to make sure its installed

sudo dpkg -L packagename

In that output you can see exactly what the binary was called and where it is installed. You can then call that file directly using terminal

Have a read here

https://www.qubes-os.org/doc/disposable-customization/

1 Like

It’s here:

/usr/local/applications/Zoiper5

and installed in the template. I cannot find the same directory in the AppVM.

Are you saying I need to type into terminal:

qvm-prefs AppVMn00bName template_for_dispvms True

and then type that other command to turn this AppVM into a template to get it to run?

Will this end up showing up in my template list if I do this and would there be any other downside?