App-VM windows dont respond unless you constantly move the mouse (post update to 4.0.3)

I have an old Dell E7470 which has worked nicely for me for some time with 4.19 based kernels,

This seems to have happened with the update to the 5.4.88 kernel. At first I thought the system was freezing but now I realized it actually isn’t, it appears just the display output is not updating. I will try and explain it as best I can here.

Now, when I boot into qubes everything is fine. I can issue commands into dom0 terminal and all my inputs display right away, things run properly.

I can even boot up vms like sys-net/sys-whonix and such without issue as long as those vms do not attempt to open their own window.

If I attempt to open any appvm window, be it xterm in debian, or firefox in fedora, anything other than dom0, the screen stops updating anything I do (typing, clicking on app buttons…etc) unless I move the mouse around, at which point the screen updates to show whatever I tried to get it to do.

For example, I load qubes and open a terminal in dom0, type in sudo-dom0-update. All the net-vms boot up and it updates and prints the progress out just fine.

Then I open a debian appvm terminal. The terminal boots up and I type in ‘apt update’. Nothing prints to the terminal, but if I twirl the mouse around in the terminal window all of a sudden ‘apt update’ appears all at once. If i hit enter to start the update it appears as if nothing is happening. Unless I keep twirling the mouse around.
Same happens if I struggle through firefox. Type something into search and nothing happens, move the mouse around and ‘poof’ the text appears. Try to load a page or use some other program, same thing.

It is hard to tell for sure, but it almost looks like literally no process continues UNLESS i keep moving the mouse. I feel like I paused an update for 5 minutes by not moving the mouse around the whole time.

Now, if I shut down the app-vm and try and use dom0 this problem now manifests itself in dom0. Shutting down every vm does not correct the issue, only rebooting does.

I feel like I should just reinstall qubes. Tthe computer is so unusable in this state it makes looking though log files painful. If it is the upgrade that caused this, all of my updates are prior to the 5.4.88 kernel upgrade so I fear I will have to rebuild all the templates again since using my backups will probably just cause this problem to repeat.

It would be nice to know what could have happened and if its fixable. Or at the least, hopefully my reporting helps prevent this in the future.

1 Like

Seems to this problem

So try the below command in dom0 terminal, then reboot.

sudo qubes-dom0-update --enablerepo=qubes-dom0-current-testing xorg-x11-drv-intel


Yes this was the problem and that fixed it.

This was a truly unfortunate problem.