Another problem connecting to WiFi

I recently installed 4.1rc1 on a Lenovo T520. Each time I boot and login I have trouble logging into the WiFi. I configured Network Manger with the said and password but it never successfully connects. If I click on the ssid in the list of available networks it tries to connect but instead it creates another entry under the network connections list rather than using the one already there. If I keep trying for a half hour or so I eventually somehow get connected but I’m not sure what exactly I did to make it successful, but by that point I have several WiFi entries for it in the connections list.

  • Are you using minimal template? have you installed gnome-keyring ?
  • Reinstall network manager sometimes work.
  • Try connecting with command line rather than keep trying for a half hour, nmcli device wifi connect <ssid> password <pwd> (hidden yes) // if your ssid is not broadcasting add hidden yes (remove () )

I see iwlwifi, is this an AX series Intel WiFi? If not, I have had trouble with WiFi authentication using iwlwifi with certain combinations (specifically the 5.10 kernel with 4.1beta that I did not have with 5.4 kernel & 4.0.4 Qubes but only with highly specific WiFi source - worked with my home gateway but simply would not finish connection with a mobile hotspot on my phone) so you may need to vary this to test.

Last night I was banging on it again and eventually got it to connect. The interface name created was usually Wsl7 with no MAC but occasionally it was changing to Wsl6 with no MAC, and finally I found an entry in the nm dropdown for Wsl6 with a MAC address, selected that and it just worked!

The even better news is when I powered it back up today it just worked, without my spending any time fighting with it. I have wasted many hours with this little bug that I could have been working.

So, from what I was seeing yesterday it appears that the MAC address being passed to the wifi interface was blank, so it makes sense that the connection was failing. Now I’m wondering why there was no MAC being configured/saved for that interface?

The same thing was apparently happening on another wifi router lastweek, so its not the fault of the wifi router but rather somehow the generation of the local wifi configuration missing some very important MAC information.

If this continues working for now I will do some more experimentation when I get home next week to see if I can nail this down. I obviously need to look into how the wifi if config gets generated.

That option was the other thing I thought about mentioning but it didn’t seem as likely (although it has personally happened to me on more than one occasion & I have commented upon it elsewhere before). Generally speaking this could just be a NetworkManager thing rather than a Qubes thing. I usually simply switch to MAC only (take the entry & drop off anything that is not MAC - say you had wls7 [MAC Here] you just edit the field to remove everything but MAC Here in that field and save it) unless I happen to forget for a bit.