Android Standalone VM install stuck in boot loop (android logo screen)

How can i install it properly? And why isn’t the GUI Qubes-Settings able to adress more than 400MB of RAM? Also it doesn’t starts properly in live mode. It seems that it is stuck in a boot loop. Only “android” displays(but it cycles with shadows over the lettering- sometimes it stops, one time at the above left that “_” displayed(only for a very short period):

Please don’t post links to images with no explanatory text. I have
no idea what you are trying to show.
You don’t say what version of Android you are trying to install, or how
you have configured the qube.

You can find discussion of this topic in the Forum, on the mailing list,
and over at Consider support for Android VMs · Issue #2233 · QubesOS/qubes-issues · GitHub

If your problem is that the installer cant find a device, then a basic
search would help you find the answer, and at least run the install. (The
same solution covers ReactOS installs)
I’ve made some notes here -

1 Like

sadly it doesn’t work.

i build two files(init_patch and patch_init) in /home/aetsch/qemu_dmargs directory in dom0, then executed cp /usr/lib/xen/boot/stubdom-linux-rootfs stubdom-linux-rootfs.orig

then i made patch_init executable and then i launched it.

init_patch contains:

qube_name=$(xenstore-read "/local/domain/$domid/name")
case "$qube_name" in
	react*)
dm_args=$(echo "$dm_args" | sed "s%-drive\\${IFS}file=/dev/xvda.*wwn=0x352540005175626.%-drive\\${IFS}if=ide,media=disk,file=/dev/xvda,id=disk0,format=host_device,cache=writeback,readonly=off%g")  ;;
esac

and patch_init contains:

#!/bin/bash
umask 077
dname=$(mktemp -d)

cp /usr/lib/xen/boot/stubdom-linux-rootfs $dname/stubdom-linux-rootfs
cd $dname
mv stubdom-linux-rootfs stubdom-linux-rootfs.gz
gunzip stubdom-linux-rootfs.gz 
cpio -i -d -H newc --no-absolute-filenames < stubdom-linux-rootfs 
rm stubdom-linux-rootfs 

sed -i "/IFS=\\$/ r /home/user/patch/init_patch" init




find . -print0 |cpio --null -ov --format=newc |gzip -9 > stubdom-linux-rootfs-new
sudo cp -f stubdom-linux-rootfs-new /usr/lib/xen/boot/stubdom-linux-rootfs

cd 
rm -rf $dname

it does not find any drive, don’t i have to made all two files executable too?

If you look close at the first screenshot you can see the .iso that I’m using.

Hi alexander
In the time it took you to type that final sentence, you could have
actually told me. “Looking close” is not an option.
Text is searchable and can be indexed: not so for a link to an image.
What is the name of your new qube?
What is the iso you are using?

Im sorry, i named my qube “android”. I downloaded my android-x86_64-9.0-rc2.iso from there:
https://www.fosshub.com/Android-x86.html#

For what it’s worth, Android X86 installs without any dom0 stubdomain modifications if using Qubes 4.1.

With R4.0, and @unman’s init_patch, looks like the qube name needs to start with “react”.

Or, change the line react*) in init_patch to the name of your qube.

*android*) will match qubes with names containing “android”.

i thought the same but i havent tried yet because im afraid to ruin everything because im a bloody noob. Can you please tell me where in the script and how do i have to throw the name in instead of the words in the script? only react* to android* ?

thank you !

tried it with that one word changed to android but does not work.

In ‘init_patch’ change the react* case statenment to whatever you
want to use for your Android machines:
e.g

qube_name=$(xenstore-read "/local/domain/$domid/name")
case "$qube_name" in
      Androi*)
dm_args=$(echo "$dm_args" | sed "s%-drive\\${IFS}file=/dev/xvda.*wwn=0x352540005175626.%-drive\\${IFS}if=ide,media=disk,file=/dev/xvda,id=disk0,format=host_device,cache=writeback,readonly=off%g")  ;;
esac

This will apply the change to all machines whose names begin with
“Androi” - Android, Android1, Androidy etc

So just change that to whatever suits you, and run the scripts again.