Android runs fine in qubes, no mouse issue, But

Just to check, I booted the “reaction” vm with kali-linux.iso and drives are still visible as /dev/xvdX
No change whatsoever. And size of /usr/lib/xen/boot/stubdom-linux-rootfs is increased to 17 MB.
I am gonna give it try. Thanks

I tried your solution. And I have passed the the problem where it said “OK. There is no hard drive…”

Now installing. Will update the post when it’s all done.

Thanks to @unman for his support, however for some reason your solution didn’t work.

Thanks to @qubesnewb your solution has worked without any issue.

1 Like

just to point out, both solutions do the same thing!

i jus try to give commands exact since you didnt sound too familar with shell commands. for ex:

you point out

cp /usr/lib/xen/boot/stubdom-linux-rootfs > stubdom-linux-rootfs.orig

and you changed to a qvm-copy-to-vm command. what you missed is the cp was meant to jus backup the original file which is always good when you are hacking things! it wasnt to copy to the vm! ps: the > im sure was an accident by unman.

you should try to understand the commands and procedure as unman describes. his github describes the issue better than i could. genarally you want to avoid copy + paste commands from internet random people like me. it is better to understand the issue and how to resolve the issue then just running the script

unman solution works, i think the diff is patch_init uses absolut path for the sed append, so if you didnt put init_patch at right spot, it wont patch. this is what i mean with understanding the goals so you can see minor issues. we are human and overlook small things some times.

The link to the procedure ( doesn’t work anymore. Could you please repost it, @unman?


The good link for @AndroidOnQubes ( + .md extension)

1 Like

Silly me!
Thank you, ludovic!
I’ll try that!

Thanks to everyone and especially to @unman. Much appreciated!!
I was finally able to successfully start to install an Android VM on Qubes with the provided procedures.

One question left related to the installation, though: When you start to install your Android VM, Google requires you to provide a Google account. If you choose to create a (test) account to be able to install the VM, Google requires you to provide a mobile phone number.

How do you manage to circumvent that (identification by mobile phone number) step to go on installing your Android VM?

NB: In my contry (and neighboring ones), you have to identify yourself to be able to buy a prepaid SIM card at any shop.

Thanks again for your support!

May I re-iterate this question a last time in case somebody had wisdom to share:

How do you manage to circumvent that (identification by mobile phone number) step required by Google to go on installing your Android VM?

Thank you!

Google just being google. Here are a few options

  • Old android
    Another option is if you have an android running a very old version laying around. Google it generally less strict with those.

  • Compile ungoogled android
    You should be able to compile a version of android that does not have google integration (the way android should be)

  • Ask on privacy forums
    They probably know better. Look for threads on or

  • VPN
    I guess this depends on the country you’re on. If you have the opportunity to use a VPN, I’d suggest you VPN into a fast growing android market. Google is less scrupulous on those markets. (note: I’ve never tried this)

It absolutely isn’t necessary to have a google account to install
Android: what makes you think this?
When you come to configure the system, you will be asked for a Google
account, but just opt out of that part of the process. You will repeatedly
be told how much you are missing out on - ignore that.
At the end of the process you will have a working Android - you wont be
able to use the Google infrastructure, like Google Play, but there are
alternatives, like F-droid.

1 Like

Not sure if this is the case, but I’ve come across unskipable “sign-in to google” prompts on androids before.

@unman, @deeplow, thank you so much for your detailed support and valuable ideas!!

1 Like

I have followed the steps above,
and successfully installed android-x86,
with several different iso,
into a stand alone VM,
but then after booting, it only give me this symbol, and nothing else,
please tell me which part is wrong ?


another iso gives me “android” only, and nothing else,
or sometimes after android, gives me blank screen with mouse only

Do we have to format the partition disk in standaloneVM with specific file type ?
But couldn’t find ext4, fat32, or ntfs
And any file type I choose to format, doesn’t appear after formatting.

I also tried Bliss OS, installed it successfully, but after booting,
it only give me Bliss’ symbol only too.
Anyone know the reason ?


Unless related, this may be worth having it’s own thread. Do you mind if I move it into another thread @nipa?

I’m sorry, I will create another thread.
New thread is created.

1 Like

patched dom0 but android-x86 install cannot find device

My psychic abilities are at an all time low.
What did you do?(Exactly)
What was name of qube that you tried to install to?
What installer did you use?

1 Like