Anaconda hangs after successfully loading the live system; Can't switch to a TTY

Hey folks, I’m having some installation issues on every supported Qubes release. My goal is to install the latest testing release, since that’s the only one that seems to work on this computer, probably due to the 5.15 kernel.
On a 4.1.1-rc1 ISO, the live system boots just fine, and systemd reports no service failures. Anaconda loads, and displays the usual greeting and “VNC disabled due to no network” message, as it prepares to load X11 and the GUI installer. Unfortunately, a second after the screen goes black with a blinking underscore in the top-left corner, the live system hangs. The blinking underscore stops, and I can no longer switch to a TTY, nor gracefully shutdown.

Specs:

  • Intel i7-9700, 8 cores, 3GHz
  • 48GB of RAM
  • AMD RX 6800 XT
  • ASUS B360M+ Motherboard
    It’s important to note that I did manage to install Qubes on this desktop before, but I have since upgraded it, with the RX 6800 XT GPU, and a new SSD.

What I have tried:

  • Disabling noexitboot and mapbs, and enabling options=console=none on the 4.0.4 ISO, but it hanged after BOOTX64.efi loaded Xen.
  • Disabling and enabling noexitboot and mapbs on the GRUB settings for the 4.1 ISO. It hanged shortly before displaying the Xen console.
  • Disabling (I’ve discovered that this did nothing, as those options are already disabled on 4.1 and above) and enabling noexitboot and mapbs on the GRUB settings for the 4.1.1-rc1 ISO. Nothing changed; the boot was successful, but Anaconda still hanged.
  • Booting into rescue mode on the 4.1.1-rc1 ISO, killing the rescue version of Anaconda, and starting the text mode installer. This didn’t work, as Anaconda either returned to rescue mode, or just displayed the standard greeting and exited with code 0. Strangely enough, systemctl would hang when I tried to switch to default mode.

I’m out of ideas. I combed through qubes-issues, but I either found different symptoms (such as Anaconda hanging on the greeting, and not switching to the screen with the blinking cursor), or it was an NVIDIA problem, which doesn’t apply here.

You can try to add nomodeset kernel option in grub.

I feel very stupid now. Thank you so much, this worked perfectly!