Anaconda 37.12.6 exception report

Hello, when installing Qubes on a new machine I got an “anaconda 37.12.6 exception report” error and when I clicked debug to open tty1 I saw the error “/usr/lib/python3.11/site-packages/dnf/ raise dnf.Exception.Error”. I saw an earlier post about a similar exception but it was a “32.24.5” exception report and that didn’t get any good responses on how to fix the problem. Is there a fix to my issue or should I get some .log files? Did something get corrupted on the usb boot stick when setting it up maybe? I’m not sure where to go from here.

First verify that the downloaded Qubes OS installer ISO is not corrupted:

Then re-verify the USB stick that the Qubes OS installer was written on it correctly:

What I did was I reformatted the usb drive and then I used the balena etcher software that I used for tails to get Qubes on the usb stick and then I tried installing it again on the new machine and it just worked. I did verify my signature for my iso and it was verified but I didn’t verify the signature to re verify the media after writing. Hopefully this helps someone in the future.

Edit: I’ll add more details here. I would use diskpart on windows to clean the usb stick, convert to gpt, clean again, create partition primary, select it, then format it to fat32, then I would use balena etcher to burn the iso to the usb stick. Sometimes when I ran “convert gpt” in diskpart I would get an error but this time I would get a success so that might be a reason why it worked but I am not sure.