AMD Virtualization is enabled but still Qubes OS won't install

AMD Ryzen 5 5600G on ASROCK Fatal1ty motherboard.
SVM mode is enabled but Qubes OS (on VirtualBox) still throws the usual “Unsupported Hardware Detected”.

I’m not sure what else can I do from this point on.
Any help appreciated.

I don’t think VirtualBox works with Qubes.

Last I tried, I was able to install, but starting any qubes would just gave me the hardware not supported error.

i forget if i ever tried installing qubes in virtual box, but it did in vmware or qemu.

I tried VMWare and I get the same error message

Did you enable the nested virtualization options?

Settings > CPU options:
Expose hardware
Expose IOMMU

If you’re talking about VMWare there is no such path as “Settings > CPU Options”, or at least I can’t find it.
There is Settings > Hardware > Processors where you choose the number of processors and Virtualization engine. I’ve already enabled “Virtualize Intel VT-x/EPT or AMD-V/RVI”.
I use VMWare Workstastion 17 Player (non-commercial)

This is what it looks like in ESXi

to enable vtx vtd in vmware try search in the google

Ok, I will install ESXi and report back

D you know how to solve the “no network adapters were detected” problem on ESXi installation?

I have only gotten that error if the installation ISO doesn’t have the driver for your network interface.

You can check google if there is a driver for your NIC, if you can find an VMware offline bundle you can build a new iso. You can use the VMware powercli to build the iso, but you are probably going to need to find a guide online telling you how to do it.

I’m not sure if the VMware depot needed to build the ISO is available for free, you are going to need more than just the installation ISO.

Maybe what @51lieal suggested is easier, and it is the only option unless you can find a driver.

as example in my guide here, i use vmware Qubes OS Installation - Detached encrypted boot and header

sys net network applet is the proof, it would work.

i use vmware workstation too.

1 Like

VMWare Workstation unfortunately doesn’t virtualize IOMMU on AMD processors.
The option is only available for Intel processors.

You can still run qubes but need to set the qubes to pv virtualization mode.
Add the cmd qubes.enable_insecure_pv_passthrough as mentioned here

After this it should work