Alright guys I got us this far LASTEST Android BLISS v15.8.6 Working

Ok here I go,

So I have been working on this for a few weeks now and found out what needs to be done BUT I now need a person or people to take us a step farther…

As of yesterday the Android Devs released the latest version of BLISS 15.8.6 and I got it to run/work in my qube…with 1 exception & 2 issues…

It installed great
It loads great (but will hang, until you edit “grub” in the kernel and then follow the instruction it list “b” to boot and… WOW it launches.

You have a full BLISS desktop “loaded” with “ROOT” permissions,termix, a lot of FOSS apps. Beautiful wallpapers. Works awesome!!! I didn’t see any “google apps” installed. I can use all the features just fine,it’s really really nice…
Here is the one I DL’ed this morning…

1.8 GB

Now to the work at hand and need help…

The 1 exception
I have to keep going into the kernel and editing out the word “quite” and adding “nomodeset xforcevesa”,
pressing “enter” and then pressing “b” to boot. Then BLISS OS 15.8.6 loads to desktop…

Issue 1

Once at the desktop on the left hand side I have a “blinking” cursor

Issue 2
After shutting down the “kernel” line edit I did for grub does not stay.

Other then that BLISS OS v15.8.6 runs great, saves the root privileges I have set and shuts down gracefully…


I may be missing something, but what’s the relationship with Qubes OS?

Can’t you mount your Bliss OS VM system storage image in some other VM and edit grub config there?

I believe someone will be happy if they can install android / mac in vm, just to play or something.

1 Like

I can confirm this allows it to boot. Thanks!

And it seems to work better than my previous experience w/ android x86 on Qubes. Before I had a double mouse but my mouse worked more like a trackpad for the other mouse. Extremely bad experience. So this is a great improvement!

I see that too. But it doesn’t look like a cursor. Rather, it looks like the blinking underscore _ from the boot log that shows just before the OS. So it’s possible that the xforcevesa or nomodeset parameters make it draw over the previous boot part and it just keeps redrawing the underscore over when it updates.


This is further confirmed when I typed on a terminal and the text was showing up in that blinking cursor as well:

My bad @B_ryr! I was indeed missing something :see_no_evil:

1 Like

@deeplow Yes it is a HUGE improvement with lots of FOSS apps/tools!!
But how do we fix the “blinking” underscore as it is the only issue I see once in the desktop environment.

@disp6252 I really don’t know how to do that and wish that the kernel edit I did would stay and that I wouldn’t have to keep editing it…

@gonzalo-bulnes… no worries my firend

If someone can address the kernel issue and then that “blinking” cursor/underscore we have a beautiful Android OS working for us

Mount your qube root storage in dispvm like this:


Is something like this:


Then in dispvm you can edit grub config in mounted image:
nano /mnt/grub/menu.lst

@disp6252 Thank you, I will give it a try in the morning and let you know… Hopefully that will work for the grub edit I have to do.

As then for that “BLINKING” cursor/underscore in the desktop environment

@disp6252 Having problems here, if you could??

Here is what I am typing in dom0 terminal…

First input:
@dom0 Desktop]$ dev=$(basename $(readlink /dev/qubes_dom0/vm-Android15-root))
terminal returns

Second input:
@dom0 Desktop]$ qubesdb-write /qubes-block-devices/$dev/desc Android15
terminal returns

Third input:
@dom0 Desktop]$ qvm-run -v --dispvm=Android15 --service qubes.StartApp+xterm &

terminal returns this…
[1] 35493
@dom0 Desktop]$ Running ‘qubes.StartApp+xterm’ on $dispvm:Android15
disp1833: command failed with code: 1


I would love to have this working so that I don’t have to keep manually editing grub before booting

YOUR_DVM_TEMPLATE is your disposable template - debian-11-dvm or something. It’s not YOUR_LVM_IMAGE (Android15).

@disp6252 ok,
But for some reason my Android 15 HVM is now gone. Where did it go?

Its not showing up where all my other domains & templates are…
Yep it’s definitely gone…

Anyway I see now my dvm is fedora-37

Changed it and now got this error

second input:
@dom0 Desktop]$ qvm-run -v --dispvm=fedora-37 --service qubes.StartApp+xterm &

terminal returns this…
[1] 12607
@dom0 Desktop]$ Running ‘qubes.StartApp+xterm’ on $dispvm:fedora-37: Refusing to create DispVM out of this AppVM, becasue template_for_dispvms=False

NVM I found my error…
and the dispvm loaded and xterm came up…

So when I type what you said… “Then in dispvm you can edit grub config in mounted image:”
nano /mnt/grub/menu.lst

I get…a blank nano file
file does not exist


following the link you sent…

next step…

[user@dom0]$ qvm-block attach disp7142 dom0:$dev

Then I do
[user@dispXXXX]$ mount /dev/xvdiX /mnt/
mount: /mnt: must be superuser to use mount...

[user@dispXXXX]$ sudo mount /dev/xvdiX /mnt/

I get

mount: /mnt: special device /dev/xvdiX does not exist...

SO where the hell did it go???

/dev/xvdiX is an example disk name and partition number X (1, 2, 3, whatever).
Find out the name of your connected root image volume and it’s partitions with these commands in dispvm:

sudo fdisk -l
sudo blkid

Most probably you need to use /dev/xvdi1 device name instead of /dev/xvdiX.

cool as long as it’s still there and “dom0” didn’t deleted or destroy it as I do not see it anymore listed along with all my other (HVM’s, Templates, domains) . So where it went to IDK., maybe stuck somewhere.

I was speaking to one of my Android buddies and is is going to try this Android 15 iso in “virtual-box” and see what happens. you know that hole " blinking" underscore/ blinking cursor. He doesn’t run Qubes OS but does a ton of VM’s in virtual-box.

Anyway thank you very much for the lesson and look very forward to understanding and using my “Qube” to the fullest.

I will tomorrow as “princess #3” is on a blazing terror right now and the Queen said it’s my turn to tame that fire…

What was I thinking, yep 3 of them…

I will let you know, thanks

@disp6252 ok here we go…

First input:
@dom0 Desktop]$ sudo fdisk -l

I get everything AND it see’s my Android HVM but only thing I am getting is… DIsk /dev/mapper/qubes_dom0-vm

Second input:
@dom0 Desktop]$ sudo blkid
only thing I am getting is… /dev/sda1: UUID
and then back to /dev/mapper/qubes_dom0-vm and seeing everything even my Android HVM. But I don not see anything in reference too
/dev/xvdiX OR /dev/xvdi1

Also Android HVM is missing from my drop down where I can choice domains,templates or other HVMS.

Those 2 terminal cmds list a ton of stuff

So what now???

So I am rerunning this and here is where I am running in to a problem from following the link you sent…
3: Attach the device to your newly created disp VM

[user@dom0]$ qvm-block attach NEWLY_CREATED_DISPVM dom0:$dev
``` what terminal?? as my dispVM has launched now and dom0 terminal does not have a cursor anymore

So I launch another dom0 terminal and type this as I have now a dispVM launched...

qvm-block attach disp933 dom0: $dev

I get error

qvm-block: error: backend vm 'dom0' doesn't expose device ' '

So wtf!!!

You need to run these commands in dispvm to which you’ve connected your Android root storage to find its device name in dispvm.

It seems you’ve run this command:

[user@dom0]$ qvm-run -v --dispvm=YOUR_DVM_TEMPLATE --service qubes.StartApp+xterm

Instead of this command:

[user@dom0]$ qvm-run -v --dispvm=YOUR_DVM_TEMPLATE --service qubes.StartApp+xterm &

Note the & at the end of a command that makes the command run in the background so it won’t block the terminal.

You need to run this command in new terminal to initialize $dev variable there:

[user@dom0]$ dev=$(basename $(readlink /dev/YOUR_LVM_VG/YOUR_LVM_IMAGE))

in the first terminal of dom0 i run these cmd’s
First input:
@dom0 Desktop] $ dev=$ (basename $(readlink /dev/qubes_dom0/vm-Android15-root))

Second input:
@dom0 Desktop] $ qubesdb-write /qubes-block-devices/$dev/desc Android15

Third input:
@dom0 Desktop] $ qvm-run -v --dispvm=fedora-37-dmv --services qubes.StartApp+xterm &

dom0 kicks back

@dom0 Desktop] $ Running ‘qubes.StartApp+xterm’ on $dispvm:fedora-37-dvm
I then have no more blinking cursor BUT dispvm6230 has started and I now have xterm up and waiting for input…

Now you are saying open another terminal in dom0 and retype this cmd…

[quote=“disp6252, post:19, topic:19357”]
[user@dom0]$ dev=$(basename $(readlink /dev/YOUR_LVM_VG/YOUR_LVM_IMAGE))

which is to me this…
@dom0 Desktop] $ dev=$ (basename $(readlink /dev/qubes_dom0/vm-Android15-root))


I have already enter that in first dom0 terminal

When following these direction on the link you sent puts me at (# 3)
Attachthe device to your newly created disp VM