All HVM's have no internet access...SOLVED

Well guys I have big issue here. None of my Linux hvm’s have no internet access EXCEPT Win 10 PRO. My win10 pro hvm can get internet with no problem. When I look at the at each hvm network settings I see…
10.137.0.xx
255.255.255.255
10.138.10.121
10.139.1.1
10.139.1.2

My win10 PRO has the same network settings “different IP” of course and has internet…

All my Linux hvms have same network settings “different ip” of course but no internet…

When I go into my resolve.conf for my Linux hvms
Nameservers are
10.139.1.1 & 10.139.1.2

When I do my ifconfig cmds in terminal to set up IP in my Linux hvms it takes.

When I set my route/gateway cmd in terminal I get either…
-No route to host
-Bad gateway

Upon researching I find this this…

And this which is from qubes os 4.0.x

So it appears that either it is low on the
“to do list”
OR
they can’t figure out how to fix this.

So I go a step farther and check in dom0 if any of these hvm’s are connected…

sudo virsh console hvm-name

And all hvms are connected BUT they can’t get internet access…

Any of my Linux hvms, no internet…
Ubuntu
Android
Arch
OpenBSD
FreeBSD

I built them all from iso. They run great only,work just fine…
No internet!!

Does anyone have ideas or solutions???

It works for me if I manually set network settings:
IP = visible_ip from qvm-prefs myhvm
Gateway IP = visible_gateway from qvm-prefs myhvm
Network mask = 255.255.255.0
DNS = 10.139.1.1 10.139.1.2

I have never done this before, could you explain please…

I do this in dom0?

qvm prefs hvm name
qvm prefs ip =
qvm prefs Network mask=

Or do I qvm prefs hvm name then edit in terminal or nano??

O’ I see now…
Now I think I understand
Thanks

@tzwcfq your method isn’t working.
In fact your hole
qvm-prefs has the same network settings that I see in the hvm qubes setting for networking.

When I do
ifconfig xn0 10.137.0.xx broadcast 10.137.0.255 netmask 255.255.255.0 up
It takes that just fine.

When I do
route add default gw 10.138.10.121

I get
route: writing to routeing socket; Network is unreachable
add net default: gateway 10.138.10.121: Network is unreachable

This is becoming a SERIOUS pain in the ass.
Never had any issues with networking for hvm’s in 4.0.x

bug?

Seems like your gw is disposable VM so you need to change network mask to at least 255.252.0.0 (or you can just change it to 255.0.0.0) accordingly.

@tzwcfq ok, I will try and report back tonight.

@tzwcfq
All HVM’s are getting network and I am upddating as I type!!!
2 of them done!!

Thank you so much for your time and understanding…

To answer your question…it was 255.252.0.0

I spent weeks trying to figure this out and a lot of research