AirVPN & Eddie, password not sent?

Not sure if anyone use AirVPN and/or Eddie, but I got a curious problem.

Eddie runs as it should from the appimage, and I can log in from a cube. But when I try connecting to any server it cycles back to authenticating right away, then keeps looping.

Tried changing the password to ordinary latin letters only in case something was sent with another encoding, same problem.

Not using any firewall for this either, so its a bit strange… Would there be anything else that could block things like a password being sent from a running application?

Can you describes the steps / documentation you followed to install it? That will help others help you.

The steps (as described) were simply these:

  1. Downloading appimage & chmod to executable
  2. Run appimage, all OK, logged in & everything worked
  3. Trying to log onto servers from within the running app & no success

So the password was clearly passed the correct way from my keyboard into the running appimage, but from there on something did NOT work - which is somehow connected to logging in with a server via the running appimage…

There is .deb and .rpm packages as well. Did you try them? If you describe to me the exact steps what you did, where you installed and how would you like to use the Eddie app, maybe i can try it myself too and report back to you.

If there is any problem you can try the AirVPN forum too, there are some very helpful people too.

If you are installing in an internet-connected AppVM (regular qube), then it’s an issue with your VPN provider and you should reach out to them directly as the forum is more for Qubes-related issues.

If you see the following issues, then it’s something to do with qubes and we can help you:

  • application disappears when you restart the qube (AppVM)
  • no internet connection in qubes

In which qube are you installing it?

First go to and generate ovpn config.

Then follow this qubes-tunnel step.

it should work.

Thanks everyone!

I’m not totally dependent on getting this app to work, seems the better option is to set aside some time to learn how to set up a VPN proxy VM manually.

But I’d like to have an easy way of changing countries too, so i’ll have a look around for similar cases in the AirVPN forum!

1 Like

You can just clone a vm with different ovpn conf, then change your network vm.

1 Like

Solved this today,

Turned out that I needed some libraries, that doesn’t show up when running an appimage of course!

Still needed to turn on network lock, guess that is either a feature or a bug in the software itself.

Curiously I also had to alter the priority to IPV4 and then 6 to pass the last hurdle when logging in.

Works like a charm now, and the app icon appears alongside the sys-whonix one.

All very practical for the Qubes where I prefer to be able to easily change country and so on, or even turn it off momentarily. Will probably use it for my Qube 2 which is all about crypto exchanges ++

If you have the spare time, could you write a short summary about how exactly you configured eddie and the AppVM itself?


I bet this might not be best practice in some ways, but its suits my needs perfectly.

What works well now is running Eddie inside of a Ubuntu Qube this way:

  1. Download Eddie & choose the appimage button first here: Eddie - AirVPN

  2. chmod the appimage file and run it (I simply use ./appimage in a terminal, then I also get to see the log live there)

  3. When the GUI is up go into settings & set the order of networking from IPV6 then 4 to IPV4 then 6.

  4. Chose Network lock before logging in

  5. Use the Eddie GUI as on any other platform :slight_smile:

I did not get around to install it via packages, might do that later - but this way of running it works very well for now at least, Its also a very easy way of using it temporarily in any Qube I guess…

1 Like