After updating to R4.2.1 my delete and down arrow keys nolonger work

Alright, so this one is just plain bizarre.

I’ve done an in place upgrade from R4.1.1 to R4.2.1 and while it solved longstanding boot issues I never expected it to… it has taken two of my keyboard keys in payment.

My “Delete” and “Down Arrow” keys on my keyboard now return “AudioMicMute” and “RotateWindows” respectively in the Xfce keyboard application. My language is English UK and I have a classic L-shaped enter key QWERTY keyboard connected via PS/2 port .

Here’s what I’ve tried so far:

  1. Changing the keyboard model/layout in the Xfce keyboard application.
  2. Removing my PS/2 port splitter and plugging the keyboard straight into the motherboard.
  3. Replacing my PS/2 keyboard with a completely different make/model of PS/2 keyboard.

In all cases the issue persists.

Any ideas whats going on here? This update is a real emotional roller-coaster…

1 Like

Could you try setxkbmap -layout gb or setxkbmap en and see if it helps?

Thanks for the advise solene but sadly that hasn’t helped.

setxkbmap -layout gb doesn’t have any impact (and setxkbmap -print -verbose 10 told me the layout was gb beforehand.)

setxkbmap -layout en/ setxkbmap en wouldn’t work and returned “Error loading new keyboard description”

I also tried setxkbmap -layout us out of curiosity/desperation, but that also had no impact on the missing keys.

It looks like dom0 has xmodmap installed, so I’ll see if I can use that to rebind delete and “down arrow”, this could get ugly…

can you try in a qube and see if the keymap is correct in that qube?

The layout inside the qubes i’m typing this from is set to “gb,us” instead, however changing it to to just “gb” has no impact, delete is still AudioMicMute like it is in dom0 :sob:.

Oh sorry, you probably meant xmodmap. Yeah good idea, that’ll be much safer :laughing:

ok so

xmodmap -e “keycode 161 = Down NoSymbol Down”

inside this qube fixes my down key.

However the same can’t be said for my delete key:

  • according to xev in this qube I’m not clicking anything when I hit my delete key.
  • according to xev in dom0 my delete key invokes focusOut, FocusIn and Keymap Notify events, but no keypress event, so I can’t get its keycode to rebind it.
  • I also tried rebinding 198 (AudioMicMute) but that didn’t work.

This is super weird because the dom0 keyboard application accepts I’m pressing a key, it just assumes its AudioMicMute. So I don’t understand how xev isn’t seeing it as a keypress.

Nevermind, my bad. I’d left a testing command for AudioMicMute in the dom0 keyboard application which was seemingly blocking it from reaching xev.

xmodmap -e “keycode 198 = Delete NoSymbol Delete”

Does indeed “fix” my delete key’s identity crisis.

Once I figure out how to persist those two commands in dom0 I should be sorted.

1 Like

Alright so I’ve used the “Session and Startup” application in dom0 to run the following command on login:

bash -c ‘xmodmap -e “keycode 198 = Delete NoSymbol Delete”; xmodmap -e “keycode 161 = Down NoSymbol Down”’

Which has solved the problem when I’m using dom0, however the fix doesn’t propagate to my qubes (So I can’t use the delete key in firefox etc), anyone know if there’s a way to solve this without editing all my templates? Or is there no propagation of keyboard config from dom0 to qubes?

1 Like