After reboot login frozen

I installed Transmission in the Fedora template afterwards I did a reboot of Qubes.

Now, I can boot to LUKS encryption.

(I am using USB keyboard and mouse (using also sys-usb))

And afterwards login is frozen (no mouse, no keyboard activity possible)

Also the GUI does not launch properly

The GRUB boot menu just allow me this:

Is there any solution to fix this?

Do other kernels boot? Perhaps you’ve run out of space in /boot generating the 4.19.147 initramfs.

Could you please explain how I can do this.
Selecting the Xen …25.config

all options show the error of the last picture I uploaded

error: you need to load the kernel first.

Press any key to continue...

Selecting the Xen…4.8 and continue launching all ends in a frozen login screen (as before)

I have seen in the GRUB Boot Menu e and c allow additional option to launch. Is there any way to launch with a limited launcher “rescue mode” to be able to login in and fix the issue ?

PS: Maybe this give more insights: This is the display when I click on the power off button:

@deeplow could you help or point me to someone who or some docs which could help me?
Or would you suggest to “simple” reinstall a blank Qubes and restore the last backup?

Hi @whoami. I’ve been tracking this thread but didn’t say much since I don’t know how to help you in this case (not much experience with the boot process).

The only thing that I can say unless it’s because of lack of disk space, the installation of Transmission should not have caused this, otherwise it would mean that some of the security properties of Qubes be broken.

At this point, you can try to get a TTY terminal by pressing Ctrl+Alt+F2 (or any other F-key). You can press Ctrl+Alt+F1 to get back on the login screen. But I woudn’t know what to do after that.

Maybe someone more knowledgeable wants to jump in on the conversation.

Does not work.

I will reinstall and try to restore from my backup :crossed_fingers:

1 Like

You mentioned you are using a USB keyboard/mouse.

  1. Were you always using a USB keyboard?

  2. Did you recently try to create the sys-usb qube via qubesctl?

If so, you might have locked yourself out of being able to use the keyboard/mouse once Qubes starts to boot (after GRUB)

  1. My question that asked if other kernels boot meant - try to select kernels 4.19.132-1 or 4.19.94-1 as shown in your 6th image.

  2. If you’re able, take a screenshot after you hit “e” in GRUB to edit the startup options so that we can see the kernel command line (this will have “vmlinuz” on the same line).

Can you clarify when exactly you are getting the “you need to load the kernel first” error from GRUB vs when you’re able to get to the login screen (but looks frozen)?

I have a sys-usb and it works (worked) for a long time. But you are right I also thought this could be somehow the issue. I just reinstalled with sys-firewall and sys-net only. I will do a sys-usb manually (not from backup) since it froze my previous res installation.

Again frozen!! :weary:
I just did a simple reinstallation with sys-net and sys-firewall only.

Lauchned Qubes afterwards (directly) in dom0

sudo qubesctl state.sls qvm.usb-keyboard

worked fine (usb-keyboard & mouse detected); did a shutdown.

Powered off again, decrypted LUKS and have a frozen login again!?
This is very weird to me since it worked several weeks without any issue.

Give me some time I will do some USB tests…
Keep you posted

:relaxed: back on Qubes OS.
I guess, I found the root of the issue. I will try to verify and post a final conclusion the coming days.

PS: Backup restore works perfectly even ssh-agent works without any extra work. I just lost the “disposable whonix”.

1 Like

I have tested several things but I could not reproduce the frozen login screen.
Anyway, a re-installation plus restore Qubes (backup) set my system back to normal.

My conclusion,it is good to do weekly backups :point_up:

Just run them every night while you sleep. There’s even a checkbox to
shutdown the machine when it’s done. It’s an easy to learn habit.

1 Like