Accidentally allowed device on Sys-Net


I accidentally moved a device on my sys-net VM. I don’t know which device it was but it was the last one and I think it said unassigned or something numbered 14 something.
I was trying to assign a wireless WiFi card.
After I figured it was the wrong one I tried moving it back to unassigned from says-net then it wasn’t allowing me. It was saying something like dom0 root error. So I turned the laptop off and every time I boot now I see either one of these photos:
Please help!!

Or this:

I get past the boot screen (I don’t have the grub menu dell xps doesn’t have it) so I go straight to disk encryption password. I enter the password then this happens.

From your log i can tell that your dn-4 device is corrupted it maybe because you force shutdown.

I can’t guarantee it would work, but you can try if you want, since you dont have grub menu.

  • Enter to qubes os rescue mode with your flash drive.
  • Follow the step and enter your disk password.
  • Since your dn-4 device is corrupted, run fsck /dev/dn-4 (Warning if you run fsck you may lose some of files, so backup is optional. Before running fsck verify your device first with fdisk -l then scroll up or you can write it to file first then read from there).
  • If there’s any prompt you can type ‘y’ and after finish, Shutdown and try Boot Qubes.

And for pci devices, It should back to dom0 after reboot.

Thank you for the response. I tried googling rescue mode Qubes I can’t find anything!

2 things before I risk losing data.

Rookie questions sorry.

  • if I backup, will the same problem occur? Like I would still need to fix it? How do I even backup when I can’t get into Qubes?


I took out the SSD and put it into another pc I have and it boots into grub! So I get Qubes option which takes me to password then it’s a black screen cursor and it keeps rebooting. (Not seeing screen from before yet). advanced options which always makes me reboot. This laptop has a nvidia graphics and it was running Qubes on it prior to me switching the SSD. I tried adding nouveau.modeset=0 on the grub menu after splash (mine has hide.usb after spash). I tried both ways putting nouveau.modeset=0 after splash and replacing the hide.usb. It keeps doing the same thing just rebooting. The resolution did get bigger though cuz of the nvidia I guess. But anyway to fix this? This might fix the issue.

Also I can boot into live usb Kali and mess around with the files if that helps. Like I see all my partitions on Kali desktop and I can get dom0 or grub files??


For rescue mode, boot from the Qubes USB drive and you should see the rescue mode in the menu.

Hey guys do I fixed it by booting into a live Kali usb.
Opened up terminal before login screen.

Kind of did what 51lieal recommended. I started playing around with fsck and e2fsck commands for my Qubes drives. I had to put my hdd into another laptop though because dellxps doesn’t allow a boot screen for some reason.

Another problem though. MY Qubes devices only shows my microphone. Sys-usb wont start on boot and gives the following error. “Start Failed: internal error. Unable to reset the PCI device 0000:00:14.0: no FLR, PM reset or bus reset availble. See /var/log/libvirt//libxl/libxl-driver.log” but i cant open it it says permission denied. Im guessing i have 2 usb drivers because only 2 devices say “USB” in them. When i move the first usb drive 00:3 it works. But none of my USBs work. When i move the second one 14:00 thats when the error comes up.