4k font size dom0 vs vm

this thread seems to be a clue. But I still have not resolved the issue. I use Fedora-32.

this thread also does not work for Fedora 32.

1 Like


It was last updated in 2019. Maybe it needs a refresh from a community member.

@user2 I would try and look up guides on how to do that on fedora 32 generically and try to implement that solution on your template. That part should not be qubes-specific. If you manage to find it that way, feel free to report back what settings solved your issue. (or maybe even update the guide).

1 Like

Could you please explain me how to adjust the font size in this VM
file explorer to have large font everywhere (path, file name,
shortcuts in the left column of the file explorer).

It depends what template you are using. If you use the standard Fedora
template, simply install gnome-tweaks in the template. Then launch your
AppVM and run gnome-tweaks and set the respective DPI value.

In other templates that do not run the gnome settings daemon, you simply
should add

Xft.dpi: 126

to your /etc/X11/Xresoruces or /etc/X11/Xresources/x11-common depending
on the distribution.

That will take care of it in all AppVMs based on that template.

I have a 4K display too and found this page invaluable:


For starting with QubesOS as my daily driver I purchased a System76 laptop with 3200x1800 resolution.

The fontsize on the login screen is extremely small and was never been able to change this. At the top there is a super tiny icon to move to twice the size but it remains relatively small.

After login the start menu, task bar and clock now shows the fonts at the right size. In appearance I have the default 192 for the Custom dpi setting and played a bit with the Window scaling but this seems to best if set to 2x. The 2x setting is pleasant but isn’t applied on the Qubes Settings screen which remained tiny small. I tried to correct that as suggested by the link provided by Sven by setting the environment variable GDK_DPI_SCALE=0.5 (e.g. in ~/.profile ) but could not find the ~/.profile page to do so.

I changed the Style to ‘Default-hdpi’ in appearance after reading the instructions on this link here provided by Sven: HiDPI - ArchWiki which was a big help for the menu bars. I figured that the System76 Galago Pro screen is a hdpi screen.

The strange thing is that when I click on the red WIFI network icon at the top, the pull-down menu with the wifi networks list remains extremely small so the source for the settings of this item comes from another source. Sys-net maybe? The others, Qubes Devices, Clipboard etc show the correct font size.

When I type in: xdpyinfo | grep -B2 resolution

the resolution shows 96x96 in every Terminal I tried (dom0, Fedora-34 Template, work etc.).

The Kfce Xresources file is empty or did not exist: /etc/X11/Xresources so I created one and changed this now to Xft.dpi: 192 but it does not seem to affect anything.

I checked and in the Fedora and Debian templates gsd-xsettings is running.

In the Fedora-34 the gsettings get org.gnome.desktop.interface scaling-factor shows the scaling factor is set to 2, I think I did that yesterday.

But it did not take this over in the work template or home template where the output of this setting is set to 1 and not to 2. On this page it says after a reboot the changes made in the template should apply on the VMs: ShellBlade

In the work template I see /etc/X11/Xresources states 192 dpi.

In the Debian template the /etc/X11/Xresources/x11-common does not exist.

I did this in the Dom0 terminal but it did not seem to change anything.

In the work terminal whatever changes I make, including a reset with gsettings reset org.gnome.settings-daemon.plugins.xsettings overrides it does not affect at all.

So far I haven’t been able to configure QubesOS for my 3200x1800 screen.

I found this post on where to create the ./profile files and that seem to work when you store that in the Dom0 and/or a Fedora Template.

Still the pop-up messages are now extremely large and the WIFI drop-down menu mentioned before is too small and overall all seems to be a bit out of porpotion. When someone would look over my shoulder now they’d think I have the ‘Teletubbies’ or ‘BabyTV’ template. At least I do not have to buy glasses for a while… if someone who knows each location of the settings could write down a 1,2,3 step instruction guide for new users with a 3200x1800 screen that would help allot of people I think.

1 Like

login screen

Edit [dom0] /etc/lightdm/lightdm-gtk-greeter.conf … specifically xft-dpi=192

red WIFI network icon

  • right click on the Panel
  • choose Panel | Panel Preferences …
  • select Items tab
  • select ‘Notification Area’ and use gear button to open properties
  • adjust ‘Maximum icon size’ (I use 44)


  • requires gnome-settings-daemon to be installed in template and running in qube (check with sudo systemctl status and look for gsd-xsettings)
  • needs to be set in each qube

I recommend using templates without gnome-settings-daemon installed and Xft.dpi set in /etc/X11/Xresources' (Fedora) or /etc/X11/Xresources/x11-common` (Debian). That way one doesn’t have to use gsettings or gnome-tweak in each and every qube. It also uses less memory and works with all apps.

For QT/KDE base apps I have found it useful to also add QT_SCALE_FACTOR=1 in /etc/environment (in the template obviously)

1 Like

I do not see a solution for the dropdown menus for USB, WIFI, QUBES MANAGER, etc. I hav applied all suggestions and these are still very small. Are they managed from within the sys QUBES?

Yes they are, you have to make sure that scaling in those qubes is the way you want it.

Thank you.

I was able to get the networking notification and drop down correct. But the Qube Manager, Device Manager, qui-clipboard, and sys-whonix have their arrow icons enlarged but the Fonts are still very small. Their titles when hovered over are also good. The Audio, Microphone, and Clipboard Contents also are good.

Any idea what might be happening?

Any idea what might be happening?

Please list all modifications you have done to dom0.

  • are you using XFCE?
  • have you at any point installed KDE?
  • what additional packages (if any) have you installed in dom0?
  • what environment variables have you declared, if any?
  • what settings files (related to GUI) have you edited, if any?

In my case:

  • stock R4.0.4 install
  • added redshift, devilspie2, thinkfan
  • added yaru-dark theme and respective icons set, ubuntu font
  • set dpi in XFCE settings and lightdm config file

… for me everything works as intended. So I think our best course of action is to see what if anything you did differently.

Also, in a previous post I had a typo. QR_SCALE_FACTOR is meant to be QT_SCALE_FACTOR. But I do not set that in dom0 – it wasn’t necessary or might have had even a negative effect.

Release 4.1
I did install KDE, no other packages in Dom0
force dpi 144 in kde
Edited /etc/X11/Xresources Xft.dpi: 144
created dpi.sh

export GDK_SCALE=2
export GDK_DPI_SCALE=0.5

Uninstalled gnome-settings-daemon

did these in dom0 and all templates, works great for all terminals and windows.

Thanks for help in advance


Release 4.1

All my experience is with R4.0. There is probably no difference.

I did install KDE, no other packages in Dom0> force dpi 144 in kde

So you are using KDE or XFCE?

Edited /etc/X11/Xresources Xft.dpi: 144
created dpi.sh

I am not familiar with dpi.sh or what would be in it. I do remember reading in several places that DPI settings made in daemon based installs (Gnome, KDE, XFCE etc) can conflict with the Xresources settings, although I never observed that myself.

export GDK_SCALE=2
export GDK_DPI_SCALE=0.5

If you are up for it, I would temporarily remove the above two for dom0 only. Reboot and see if and what difference it makes.

Uninstalled gnome daemon

Can you run ps aux | grep gsd in dom0? What do you see? xfsettingsd? Something that starts with gsd-?

did these in dom0 and all templates, works great for all terminals and windows.

That’s because most (but not all) templates come with gnome-settings-daemon and once you deinstall it the Xresource way works perfectly. However in dom0 you either run XFCE (with the xfsettingsd daemon) or KDE (don’t know of hand how their daemon is called). So this ‘overwrites’ whatever you did in Xresources, or as others claim even interferes with each other.

While I can’t tell you what the issue is, I have a recommendation how I would go about figuring it out:

  1. temporarily undo all modifications you made (Xresources, dpi.sh, environment variables GDK_ …) in dom0
  2. reboot and select XFCE at login screen
  3. set DPI in XFCE settings and reboot again
  4. verify if at least under XFCE everything now works as expected (it should)
  5. reboot select KDE at login screen (if KDE is what you want to use)
  6. check that KDE settings in GUI are all set to the DPI you want
  7. see how the behavior is now, if it’s not to your satisfaction…
  8. reintroduce your modifications one at a time(!), reboot and see what if any difference it made.

(all of the above for dom0 only, no need to touch your templates!)

Good luck!

Thanks for the directions…a couple things to clarify

I have both XFCE and KDE installed, using KDE. I have been loging in back and forth to sort of see how the changes affect each. Does it take a full reboot to see the affects?

The dpi.sh changes were suggested in this thread earlier by trounces and here Tiny Icons - #6 by Walker

I tried running ps aux | grep gsd and do not get xfsettingsd and gsd only shows at the end of line --color=auto gsd and gsd is in red.

Working on taking your troubleshooting advise.

Thanks again.

1 Like


Does it take a full reboot to see the affects?

The way I understand it: no … but I am not 100% sure, so to remove any chance of interference I recommend to do a full reboot. It might cost you a minute every time you do it, but might end up saving you days.


  • start with a known clean state (e.g. reboot)
  • make one change at a time (so you can clearly attribute any observed change)
  • if in doubt to a-b-a type of experiments (do something, undo it then do it again)
  • keep notes (to discover patterns, share observations without forgetting things)

Sven, thank you for all the help. I usually follow your principles, sometimes just need reminder. a variation I thought I had covered seems to work.

These settings both affect the sizing of fonts.

export GDK_SCALE=2
export GDK_DPI_SCALE=0.5

But the GDK_SCALE= seems to only accept integers. Setting only GDK_DPI_SCALE=1.5 did what I needed.

Thanks again.

1 Like

Hi. I’ve tried to follow these instructions for a 4K 15 insh screen. So far I face two problems. The Windows colour bar (showing Qube / Document title / application) is not resizing correctly. its text is clipped/cut. And second, VLC no longer shows videos (Debian Qube) because of the 4K resolution. Before I reduced the reslution to 1080p.

As for the following two settings:
export GDK_SCALE=2
export GDK_DPI_SCALE=0.5

Should I include them in Dom0 in addition to the templates, and how can I achieve that?

In case you are using (the default) XFCE in dom0, simply set the DPI in the Settings App. The window decoration unfortunately do not obey the DPI setting in this version of XFCE, but there is a DefaultHDPI style available that should work. See under Settings | Windows Manager.

1 Like