4k external Monitor does not work

Hi, does anyone know how I get 4K working on my Qubes? I use an Nitrokey Mini-PC + Philips 278E Monitor and it works with 2k but if I go to 4k the screen turns to black. I used this “qvm-features dom0 gui-videoram-min 64000” in dom0 and after that 2k works, but no 4k. I even tried gui-videoram-min at 128000 but it does not work. I do also see the booting process but before entering the password to encrypt the SSD the screen turns into black and for the user password the same, black screen…after entering the user-PW the Monitor turns on but only with 2k …Any ideas? P.S. I tried Linux Kodachi via USB and this works great with 4k.

Did you check whether there is a setting in your BIOS where you can set the video memory size that your internal GPU is allowed to use?

I remember that I stumbled across something like that with a 4K display a while ago.

Thx for your answer! I did not check this, but I will have a look at it. Its a Coreboot + Tianocore UEFI, I am not quite familar with that…new PC. The seller said I should use a DisplayPort Cable instead of my HDMI cable, i didn’t think at this at all. That connecting a monitor could get so difficult… :wink:

Did you try to increase the video RAM buffer?

use a DisplayPort Cable instead of my HDMI cable

Yep, same here with integrated Intel HD 630 graphics and 32-Inch UR590C
UHD 4K Samsung monitor:

  • limited resolution via HDMI
  • perfect, out-of-the-box 4K without having to do anything when using
    DisplayPort

Yes, I think that should increase the Video Ram: “qvm-features dom0 gui-videoram-min 64000”.

I just orderd one DisplayPort Cable, will try that. But what I do not understand, (HDMI+Monitor+NitroPC) works great with 4K @ my Linux Kodachi, so I thought cable was not the problem.

(HDMI+Monitor+NitroPC) works great with 4K @ my Linux Kodachi,

Oh, so it works with HDMI on the same HW using a different software
install … then it’s probably not the cable.

But since you already ordered it, might want to try in any case. Please
let us know how it worked out.

Hi Sven, I just connected the DisplayPort C. and it worked!!! Thank u so much for your help!
Is there a Monero Address, where I can send a little donation to you and/or or Qubes Community?

1 Like

Is there a Monero Address, where I can send a little donation to you
and/or or Qubes Community?

Please see Donate to Qubes | Qubes OS

There is no Monero address though. Glad it worked out for you!

There is no Monero address though.

I need to correct myself, I just learned that it will be added very
soon. Thanks @deeplow!

If you peek into the changed files of the PR you can already see the
Monero address but it would probably be a good idea to wait until the PR
is closed and the address is publicly visible at

Ok, thank u! As soon its available I will donate some!