4k - Display Font - different font size in terminals

The fonts are quite small on a 4k monitor when I start a terminal via the System - Tray - Qubes OS Icon → Domains → Run Terminal.

If I start a terminal via qvm-run from Dom0 the fonts are shown in the correct size from config:

I find this quite convenient to call the terminal from the system tray via the menu. Unfortunately the font is too small to work in templates or AppsVM.

In the screenshot I call the left terminal with the Dom0 command qvm-run. And the right terminal was started via the System-Tray → Qubes/Domais Icon → Run Terminal

Where do I set the environment variables so that the correct DPI for a 4-K monitor works?


1 Like

I think you have to change the XTerm font settings in each template. At least, that’s what I did. I’m actually surprised you were able to get different results at all.