4.2: restored 4.1-qubes are not forwarding traffic due to qubes-core 4.1 packages installed

Good day to everyone,

I’ve some issues after the 4.2 upgrade. So, 4.2 was freshly installed and the networking qubes (debian-12-minmial) that were running fine in 4.1, are restored from backup, but now they are not forwarding traffic anymore.

So if I use my 4.1 network-stack:

sys-firewall → sys-wireguard → sys-net

then sys-net and sys-wireguard can connect to internet, but everything else is not forwarded from sys-firewall. E.g. ping to on sys-firewall fails with: “From qubes-eth0-ip icmp_seq=1 Destination Host Unreachable”

So I started to debug this and deployed wireguard again but on the debian-12-xfce template which was shipped with 4.2:

sys-firewall → sys-wireguard42 → sys-net

And this works fine out of the box.

So I know about the nftables/iptables issue on 4.2 and thought, no problemo just edit nftables, but it seems that the 4.1-templates are still equipped with 4.1 qubres-core-packages, even after running updates on them and this is causing some problems, which can’t be solved by just add some rules to nftables.

So is there any way to update the qubes-core packages in the templates, to 4.2 with some commands OR do I have to re-install all my templates to achieve this?
I already tried to edit the apt.sources to change the 4.1 to the 4.2 repo but this has unresolved dependencies and trying to remove and reinstall xen-utils-guest is just the road to breakage:

The following packages have unmet dependencies:
 xen-utils-guest : Conflicts: xen-hypervisor-common but 4.17.2+76-ge1f9cb16e2-1~deb12u1 is to be installed
E: Broken packages

root@debian-12-min-xxx-yyy:/home/user# apt remove xen-utils-guest
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
The following packages will be REMOVED:
  qubes-core-agent qubes-core-agent-networking qubes-gui-agent qubes-vm-dependencies
0 upgraded, 0 newly installed, 5 to remove and 22 not upgraded.
After this operation, 1,021 kB disk space will be freed.
Do you want to continue? [Y/n] 

Thank you for your valuable time and any hint provided

Download and run the following script on your restored 4.1 templates to update them to Qubes 4.2 repositories:


Thank you really much, I’ll try this

To upgrade your templates 4.1 to 4.2, use this script:
put the script inside templates you want to update and launch it.
it will switching them to 4.2 :slight_smile: (clone them before, just in case there is a trouble)

oops, too late! lol

Thank you too for your super fast response. Even I looked through open git issues I did not found this script. And yeah, it works fine. Saved my day.