4.2 install issues

I have tried to install 4.2 multiple times with no luck. The issues I have had:

  • iso test doesn’t complete, even though I used the dd command to create my usb stick.
  • if I just do an install, it succeeds, but the first boot gives an error

Worse yet, I am unable to get to a terminal prompt or connect networking.

Did you verify your downloaded ISO that it’s not corrupted?

Did you re-verify your USB stick after you’ve flashed it?

1 Like

Yes, I did. Signature and hash all are good. I tried creating a USB stick from Linux using dd, and from windows using rufus, as documented.

Try to re-verify your USB stick after you’ve tried to boot from it and the image test failed.

How do I verify the USB stick? Is there some command that I can use to compare it against the verified ISO file?

I’ve linked the guide in my first post:

As I said, I did verify the ISO download before writing it to the USB stick. I do not know how to validate that the USB stick was created properly.

The link @apparatus shared, says:

dd if=/dev/sdX bs=1M count=$(stat -c %s /path/to/iso) iflag=count_bytes | sha256sum

You’ll have to replace sdX with the device name of you USB and /path/to/iso with the path to where you have the ISO stored on your computer.

I get 26203f27c68ef757f0bd01f194c466c5629c0a5996859db92b37e323eee8714c, which matches the digest.

I suspect 4.2 and my laptop are at odds. It’s a hp elitebook 840 g5. 16gb ram, 256g ssd. I had no issues installing Linux Mint 21.2.

I wish Qubes was a little more user friendly during the install. Things like giving better progress reports, and info on how to address failures. I’m pretty familiar with Linux. I have a MSEE and MSCS. I shouldn’t have to be a rocket scientist to get this installed.

So what do you have after you boot the Qubes OS?
Just empty screen?
You can switch to TTY with Ctrl+Alt+F1 - F12.

Try to run the configuration command:

sudo qubesctl --all state.highstate

And check for errors.

No, I had a GUI, but it didn’t seem complete. I could find no way to access a dom0 terminal.

After my failure to install Qubes, I installed Linux Mint to validate that there wasn’t something intrinsically wrong with running Linux on the laptop.

I will reattempt an install of Qubes, and capture pictures or videos to illustrate these issues I ran into:

  • unable to validate and install from the usb
  • error during install when selecting install without validate
  • inability to continue the install via terminal

Might take me a day or two to get to it.

Does the error happen before or after you get the “INITIAL SETUP” menu?

If it happens after, you can select “QUIT” at the bottom left corner – it should allow you open terminals in dom0 (Alt+F2 and enter xfce4-terminal ?) and restart the INITIAL SETUP by running:

sudo /usr/libexec/initial-setup/initial-setup-graphical

Note: I’m guessing - I’ve not had the issue you are facing.

Rather than rely on my memory, I will just start over and make copious notes, take pictures and videos so I can present a cogent summation of the issues.

Sounds like a good plan … and if the error happens after/during the “INITIAL SETUP”, then you can redo the installation, stop the “INITIAL SETUP” via “QUIT” and get a clean dom0 and then re-start the “INITIAL SETUP” from a dom0 terminal and have a second terminal to inspect log files …


It looks like I’ve hit the watched pot syndrome. It installed this time since I took pictures and videos during the whole process!

My prior attempts I tried different combinations.

  • USB creation: via dd on linux mint, via rufus on windows, via etcher on windows
  • Destination: external 128gb m.2 sata drive connected via USB C, internal 256g m.2 NVME drive

I did see one note about USB creation:

" Note: Using Rufus to create the installation medium means that you won’t be able to choose the “Test this media and install Qubes OS” option mentioned in the example below. Instead, choose the “Install Qubes OS” option."

I may have run into that - it is a shame that the qubes installer doesn’t disable that option if it isn’t available. Maybe it can’t tell?

For this run, I used a USB drive (actually a microSD card in a USB adapter), created it with dd on linun, verified the usb against the ISO file (which I had already verified with SHA256).

I installed to a 256mb m.2 sata drive connected via USB-C

All installs were done on the same laptop, a HP Elitebook 840 G5 with 16GB of ram.

This last install I kept all defaults.

I’m going to play around with things for a while before I decide my final configuration.

I have had this exact same problem installing 4.2.2.

I tried ISO files from 3 mirros; and building the boot/install usb stick using 4 different versions of Rufus. The result was the same in all cases. I also tried Ventoy but the Qubes installer would not accept the source ISO.

This is a Dell laptop on which I have been installing and upgrading Qubes since 3.x.

I gave up and went back to 4.2.1 which has (re)installed without any problems.

When I find the time I will attempt an inplace upgrade from dom0.

sudo qubes-dom0-update -y qubes-dist-upgrade

does not install qubes-dist-upgrade.

Does anyone know where I can find - or how I can install this tool?


Did you install Qubes OS 4.2.1 or 4.1.2?

It was 4.2.1.

However, to confirm I checked (cat /etc/qubes-release). Which tells me that the version now installed on my machine is 4.2.2.

To be fair I accidently executed a qubes-dom0-update where I enabled the testing repo (–enablerepo=qubes-dom0-current-testing). And I had been considering wiping the install and reinstalling 4.2.1.

qubes-dist-upgrade tool is used to upgrade major release versions e.g. from Qubes OS 4.0 to Qubes OS 4.1, from Qubes OS 4.1 to Qubes OS 4.2 etc.