4.1 USB serious issues

Ok guys big problems here, so I am just going to throw it out.

So during boot up I keep getting a black screen for a about 2 seconds that states up in top left corner of monitor…
WARNING!! USB deviceabc123: has access to dom0 ( but this warning goes so fast I can’t even read all of it)

#2 This is the biggest problem
Make it to loging screen but for some reason no mouse or keyboard again but before I logged out USB mouse/keyboard was working fine. So I have to HARD SHUT DOWN computer and bring it back up and then mouse key board works…
Now we all know here that “you can’t keep HARD shut down a computer” because somewhere along the line a piece of hardware will break,short out… and if this happens I will be I will be p****ed off to say the least…

#3 it’s workable
Keep getting popup box to allow USB mouse access for dom0, I hit enter and get some kind of “sticky key” fly out up by time. It’s ok, just don’t understand why I have to keep doing this ever time I can login.

its just a warning, meaning that yout have usb that attached directly to dom0.

If you can make it simply i maybe could understand.

i don’t know about stucky key things, but if you want automatically allow mouse for dom0, simply edit /etc/qubes-rpc/policy/qubes.InputMouse

inside you will have something like
sys-usb dom0 ask,default_target=dom0

change it to
sys-usb dom0 allow

@51lieal thanks for getting back…

So for #1
That’s fine if it’s no serious concern. But man does that error disappear fast, in a blink of the eye.

So for #2
I will be doing a BIOS update later to see if it fixes this USB issue. Upon reading manufacturer BIOS latest notes, they state it is a known issue (USB’s become unusable at boot) with the USB controller and this update addresses this. So keeping my fingers crossed.
But to answer your question. This USB mouse/keyboard not working only happens IF I leave my computer off for a while. Let me explain…
I use my qube and mouse/keyboard work fine BUT I shut down for the night. In the morning I get up and fire up my qube and all of the sudden the mouse/keyboard do not work. So I have to HARD shut down and reboot then mouse/keyboard work. Which leads me to believe controllers, which I went to manufacturer site and researched BIOS/USB controller issues and what do you know I found the issue and latest BIOS update to hopefully addressed this.
But this mouse/keyboard not working only happens once I get to qubes login screen.
Works fine when I am in BIOS, which leads me to believe it a qubes 4.1 issue but I will update BIOS.
Make any sense to you now?

For #3
So in dom0…user@dom0 $ nano /etc/qubes-rpc/policy/qubes.InputMouse

inside you will have something like
sys-usb dom0 ask,default_target=dom0

change it to
sys-usb dom0 allow,default_tatget=dom0
Am I Right in this thinking???

try turn off auto start sys-usb for a few test, booting, leaving, etc. if its still work then maybe the problem is in your sys-usb.

no need for ,default_target=dom0

@51lieal if I do what you are saying…
“try turn off auto start sys-usb”

How am I going to use my mouse and keyboard as they are USB?

And if I find out it’s my sys-usb, how would I fix this?

well if sys-usb is not turned on at start, then your usb controller is still in dom0, that’s why you need to turn off automatically start on sys-usb

So will it start then after I am in qubes with my external USB SSD’s attached or will I then have to start sys-usb?

Or how about I just delete it and recreate it?

Because I used the way to create sys-usb like I did for 4.0.x

You know I just had to brain burst. I installed disposable sys-usb as well as disposable sys-net when I did my fresh install of 4.1.
Do you think the disposable sys-usb could be causing my problem at logging?

hmm nope, i did use disp vm on all sys-*, i just want to know first, if sys-usb is never start, would the problem is occur or not before talking about solution.

Great, when I get home from work tonight I will test and get back to you

Well I have unchecked “auto start” & “provides network” for sys-usb and all my problems are gone.
But now all my external USB drives and thumb drive now show in dom0…
Is this a bad thing?

And my network connections are working great as wekll

So what next? For this “sys-usb”

Also for some reason if you remember when I finally got to login to my Qube and I would get this window popup asking me to allow “mouse” to connect to dom0 and I would click ok and then get a fly out winow stating “sticky key was created”. Well now thats gone as well…

for security it’s really bad thing because we don’t know if the usb is ‘bad’ or not, but a whole world (other os) are doing this so it’s ordinary.

ok so, what i don’t understand is the ‘sticky key was created’, normally that if you put a mouse policy to ask, there will be a notification coming out, after pressing tab tab tab and ok to confirm, there should be nothing come out.

check /etc/qubes-rpc/policy/qubes.InputMouse
what policy you have inside this file ?

I thought so (dom0) now has all my external drives and I don’t want that.

So tonight I’ll check what you need me too and let you know.
Man I hope we can get this fixed “don’t like sys-usb not working right + now dom0 has all USB shit” and sometimes sys-usb works other times it doesn’t…

Good morning,

So I "check /etc/qubes-rpc/policy/qubes.InputMouse"
what policy you have inside this file ?

Also I did my BIOS update and system runs smoother now

I enabled it, but still same issue with sys-usb.

And for some reason once I get to login and get to desktop qubes will boot loop. Hole dam computer reboots

i really bothered by ‘sticky key was created’ can you take a pict, and well if you don’t want to confirm mouse access just use this sys-usb dom0 allow

I have not made that change that you have said I could do. But here

Once I log in I get this window…

I only click enter on my keyboard and then this popup "sticky’ shows up…

So I got back from running around and I fire up my qube and for some reason it didn’t boot loop/restart comouter…after I logged in
Strange my the bios update I did fixed it, man I hope so!!!