4.1 rc3 with Dell latitude e5470 : Dual Boot and wifi issues

Here is my partition setup currently. Still has some errors. What exactly?
Can i get some normal explananation with / and /swap ? I just want to resize a bit of windows to free space and try system.


Theres another option in comment reply posting im trying to edit in Blivet-Gui partition manager with LVM2 partition and in it needed to make something inside also.





How can i delete this reply? Now i put all in one post. This picture is duplicate.

@deeplow

Heres LVM2 partition test, also not working.
How to delete this reply, cant. I put all in one post, since now i can put more pics in one post. Admin plz detele this reply. I move deez pics in one post, since now i can put more pics in one post.





Just use automatic configuration, then delete some partition you have created in windows 10 diskmgmt, then proceed installation.

This automatic? With encrypt on? And thats it? Automatic will delete all. I want to keep Windows 10

yeah. there will a pop up because you need some space, delete some partition that you have shrinked from win 10 and proceed. it’s okay to upload image again if you not sure. as long as you don’t click Begin Installation, everything you configure in gui wouldn’t be applied.

no it wont delete all, read my post above, if you still unsure, do backup on important file first in win10.

In windows theres nothing. I backed up. Just keeping in case will need to do TPM 2 to 1.2 downgrade to test 4.1 with AEM. I like Kubuntu, doing a lot bugreports for all Ubuntu distros, but now will test Qubes OS.
Oh, wow. Cool. This Automatic needs to be renamed Automatic resizing partitioning wizzard.
Otherwise i thought other 2 options do the resizing, but Automatic i thought will take all.
So i selected windows 10 partition, shrink, no button to finishing shringing, so on shrinking cant do any other options, but clicking shrinking needs to be last option that keeps the amount in field renamed Total reclaimed space for Qubes Os sinstallation. That would be needed to write also. 2 bug suggestions for better UX understanding of simple dimple installers.
Thanks!

well this has nothing to do with qubes, since we use anaconda installer.

btw, i would suggest that you shrink partition in win10 diskmgmt first, so you know the exact partition / size, then back here and delete the partition, after that reclaim space and just proceed with installation.

1 Like

Got in setup resizing info already. Anaconda doing all commands.
Yes, ive read all the time in all installers to do better windows resizing, in case some error bug happens. Havent yet got one, but testing with clean systems. On real system need better to have windows disk managment use to do resizing to resize their systems.
Im waiting until some bug happens with linux resizers, looks like gnu/linux installers do so far allways perfect resizing.
Im specially allways, if installers offer resizing, then letting linux do that, since ive never yet got any bug. Im just doing without windows resizing to find error and bug in linux resizers gparted editors.
Now already all systems allow at least windows resizing. Next step would be also linux partition moving and resizing.
And got system up!
Soon ill write what to do to make Qubes OS working.
Should i test 4.0.4 also? It was not starting in UEFI as 4.1, so i read that a lot something new, so maybe not to even try 4.0.4 since only new year need to wait and wake up from hangover and 4.1 could be decided that is final?

So now after installation Qubes started, i didnt noticed windows choosing option.
So i entered disk decrypt password once, it continued loading, but still asking disk password, then 2nd time used wrong password, then still asking, 3rd time entered same 1st time entered correct password. It loaded slowly a bit more. Found already that left right i cen get console and this is error i got. Then i pressed CTRL+D and now its not moving.
Rebooted, from bios boot menu checked windows is working. Was only windows selection, thats normal since disk size changed.
So windows working, thats cool.

Rebooted again and let qubes finish loading. Loads long, entered password. Turns out password i forgot?

Maybe too many other bios setting i set up? I turned on all, what was not on in bios, except secure boot i kept off.



just go with qubes 4.1-rc3, looks like it would go stable in 1-2 months


this called dracut emergency shell, could be you entered wrong password or wrong fstab, normally with automatic partition there should be no issue with fstab, since you are installing in middle sector this could be an issue too.

what’s the ouput of :

lvm lvscan

if output is “inactive”

then try

lvm vgchange -ay qubes_dom0
lvm lvchange -ay qubes_dom0/root
exit

see if you boot into qubes os.

I would suggest that you use separate disk instead of dual booting in the same disk, or if you want, you can install win 10 in beginning sector - 120GB , then leave the rest of space unpartitioned, so qubes os isn’t in the middle sector.

Good morning. I fell asleep while testing. Now i can write a book- adventures on 1st day of mistakes with qube sos. Now got all running but now turns out Dell lattitude e5470 wifi 8260 not working. Found google discussions. There no problems mentioned. Maybe tpm 2.0 makes it not work? Is that possible?

So back to experience story where we left on wrong password and in end where im stuck now:

Ah, yes lol i made password mistake not looking at keyboard i set one symbol lower when setting passowrd. I got in now guessing correct. Tried symbol one left, one right, one down. Worked when found correct.
Now before finishing installation went into CTRL+f1 or f2 did again ctrl+alt+del estart on purpouse this time with worng password to check commands.



Heres a cool effect picture not related.

Commands shows that worng pass, yes?

So now i rebooted again and now continued with correct passw.
In setup i changed only to default to be Debian 11
All loading, installing.
Language change shows multiple english and come C language??

After some time loading of of installation moving all the time then this last template stopped moving. Mouse moves, but this last loading bar isnt moving, but i will wait this time.


Ctrl+F1 just hide the mouse, TTy was not openeging any tty. ctrl+f2 got back showing mouse. So i toggle multiple times like that until the non moving loading gone and showing LOG IN.
Cool BUT

FORGOT user PASSWORD
Oh, then it asked for log in.
OH OH. Now this password i made also such that i dont remember? Tested multiple. Ok will remake password or reinstall.
Booted usb install recovery. Something didnt like after auto detecting sda6 and unlocking it.
Got shell.
Found commands to fix (space for links later)
I got into root cause was no root pasword set even if root disabled?
Changed one symbol password- got warning palindrome (what?)
Changed different passowrd- got warning 8 symbols needed (what?)
Changed another password- got warning dictionary based word something (what?)
Changed another password- ok.

Whatever.
Rebooted
Logged in.

QUBES WORKING
Testing i dont know what. Something Whonix asking to do some wizzard for internet. its not moving- maybe cause no initernet.

Getting to know system. Manually adding wifi.
Morning- woke up. So all working Except wifi Showing only ethernet
Went to connect to lan.

Updating
Opened some disposable firefox.
Update app star in notification came up.
Clicked update not from there but from menu qubes update.
Clicked all. Updating. Very slow.
Clicked disposable firefox about- it also starts updating.
Got in updated finishing updating- but error for whonix-ws-16.
After update process finishing did again that what failed alone- but circle was not moving rotation.


Also got this error before on after reboot and another update test since wifi wasnt still updated to work. Or maybe i opened something and it was this error while updating.

No wifi still.
Again updating all.
Something failed- fedora34
Doing it alone- again circle not rotation moving around.

Disposable firefox opening it asks for restart it. Restarted. Updated version. Closed. Reopened disposble firefox. It start updating again.
Other updates someting failing.
Clicked only failed one. All ok.
Did again all update- all went ok. But why its showing that each time something updated even if i updated all- Succeeded 2 )changed-1(

Wifi troubleshooting and how i rocked vm templates and got back correct or incorrect
Dont remember if sys-net had wifi 8260 in or i shut down each that said that cant shut down that need to shutdown other something so shut down each template. So i added 8260 wifi or it was there.
Starting all. No wifi still
Clicked usb devices Broadcomm (im thinking is this my wifi with differend name now? lets try) clicked to connect it to sys-net.
Added in usb i think wifi 8260.
Closing 4 active vm templates.
Got some error. App hanging.
Reboot. sys-usb not starting.
Removed sys-usb with commands.

sudo qubes-dom0-update --action=reinstall qubes-template-sys-usb
gvm-template: error: Same version of template 'sys-usb' not found.
qvm-remove sys-usb

Removed

Trying to get back clean one

qvm-get-image sys-usb
usage: qvm-get-image [-h] VMNAME SRC DST
qvm-get-image: error: the following arguments are required: SRC, DST


qvm-template sys-usb
usage: qvm-template [--verbose] [--quiet] [--help] [--repo-files REPO_FILES]
                    [--keyring KEYRING] [--updatevm UPDATEVM]
                    [--enablerepo REPOID] [--disablerepo REPOID]
                    [--repoid REPOS] [--releasever RELEASEVER] [--refresh]
                    [--cachedir CACHEDIR] [--keep-cache] [--yes]
                    {install,reinstall,downgrade,upgrade,download,list,info,search,remove,purge,clean,repolist}
                    ...
qvm-template: error: argument command: invalid choice: 'sys-usb' (choose from 'install', 'reinstall', 'downgrade', 'upgrade', 'download', 'list', 'info', 'search', 'remove', 'purge', 'clean', 'repolist')
qubes-dom0-update --enablerepo=qubes-templates-community qubes-template-sys-usb
Redirecting to 'qvm-template install --enablerepo=qubes-templates-community sys-usb'
usage: qvm-template [--verbose] [--quiet] [--help] [--repo-files REPO_FILES]
                    [--keyring KEYRING] [--updatevm UPDATEVM]
                    [--enablerepo REPOID] [--disablerepo REPOID]
                    [--repoid REPOS] [--releasever RELEASEVER] [--refresh]
                    [--cachedir CACHEDIR] [--keep-cache] [--yes]
                    {install,reinstall,downgrade,upgrade,download,list,info,search,remove,purge,clean,repolist}
                    ...
qvm-template: error: Template 'sys-usb' not found.

Not easy to get it back. Found other commands googling
qubes reset template
removed sys-usb reinstall qubes os

https://groups.google.com/g/qubes-users/c/-vomVY-Js5k

sudo qubesctl state.sls qvm.sys-usb

Template clean back and working and showing again webcam and somekind broadcom.

heres related help but wasnt solution from here but other interesting commands

Real wifi troubleshooting
Found some commands and website with exactly 8260 mentioned. But for me was different- didnt work still.

… continuing in next reply. no space for post.

I read your every sentence, and glad that you can fix it by yourself.

Maybe the problem is because your default vm is debian 11 ?
have you try changing default vm (or at least sys-net) to use fedora 34 / 35?

Contining post of Wifi troubleshooting

As i mentioned before- wifi i put in sys-net when shutting down each related templates.
Lan and wifi are in sys-net template.
Maybe something else also need to add from drivers in here?
Hmm. cant post clipbord screenshot or drag here screenshot. Very secure. But what to do when i want to allow for second?
I cant put screenshot here, cant paste dom0 screenshot clipboard here and cant move saved screenshot file to another vm

https://www.google.com/search?q=qubes+os+not+showing+wifi

in sys-net terminal all is same as in link



user@sys-net:~$ lsmod | grep iw
iwlmvm                507904  0
iwlwifi               364544  1 iwlmvm
mac80211             1142784  1 iwlmvm
cfg80211              995328  3 iwlmvm,iwlwifi,mac80211

user@sys-net:~$ sudo rmmod iwlwifi 
user@sys-net:~$ sudo modprobe iwlwifi 
user@sys-net:~$ sudo rmmod iwlmvm
rmmod: ERROR: Module iwlmvm is not currently loaded
user@sys-net:~$ sudo modprobe iwlmvm
user@sys-net:~$ sudo rmmod iwlmvm
user@sys-net:~$ sudo modprobe iwlmvm
user@sys-net:~$ sudo rmmod iwlwifi 
rmmod: ERROR: Module iwlwifi is in use by: iwlmvm
user@sys-net:~$ sudo modprobe iwlwifi 
user@sys-net:~$ sudo rmmod iwlmvm
user@sys-net:~$ sudo rmmod iwlwifi 
user@sys-net:~$ sudo modprobe iwlwifi 
user@sys-net:~$ sudo modprobe iwlmvm
user@sys-net:~$ modinfo iwlwifi | grep -E '^(description|author|depends):'
bash: modinfo: command not found

Back in dom0 terminal

lspci -k
01:00.0 Network controller: Intel Corporation Wireless 8260 (rev 3a)
	Subsystem: Intel Corporation Device 0250
	Kernel driver in use: pciback
	Kernel modules: iwlwifi

modinfo iwlwifi | grep -E '^(description|author|depends):'
author:         Intel Corporation <linuxwifi@intel.com>
description:    Intel(R) Wireless WiFi driver for Linux
depends:        cfg80211


modinfo iwlmvm | grep -E '^(description|author|depends):'
author:         Intel Corporation <linuxwifi@intel.com>
description:    The new Intel(R) wireless AGN driver for Linux
depends:        iwlwifi,mac80211,cfg80211

modinfo iwlwifi
doesnt have 8260

heres full list of result

Summary modinfo iwlwifi

filename: /lib/modules/5.10.76-1.fc32.qubes.x86_64/kernel/drivers/net/wireless/intel/iwlwifi/iwlwifi.ko
license: GPL
author: Intel Corporation linuxwifi@intel.com
description: Intel(R) Wireless WiFi driver for Linux
firmware: iwlwifi-100-5.ucode
firmware: iwlwifi-1000-5.ucode
firmware: iwlwifi-135-6.ucode
firmware: iwlwifi-105-6.ucode
firmware: iwlwifi-2030-6.ucode
firmware: iwlwifi-2000-6.ucode
firmware: iwlwifi-5150-2.ucode
firmware: iwlwifi-5000-5.ucode
firmware: iwlwifi-6000g2b-6.ucode
firmware: iwlwifi-6000g2a-6.ucode
firmware: iwlwifi-6050-5.ucode
firmware: iwlwifi-6000-6.ucode
firmware: iwlwifi-7265D-29.ucode
firmware: iwlwifi-7265-17.ucode
firmware: iwlwifi-3168-29.ucode
firmware: iwlwifi-3160-17.ucode
firmware: iwlwifi-7260-17.ucode
firmware: iwlwifi-8265-36.ucode
firmware: iwlwifi-8000C-36.ucode
firmware: iwlwifi-9260-th-b0-jf-b0-46.ucode
firmware: iwlwifi-9000-pu-b0-jf-b0-46.ucode
firmware: iwlwifi-SoSnj-a0-mr-a0-59.ucode
firmware: iwlwifi-ma-a0-mr-a0-59.ucode
firmware: iwlwifi-ma-a0-gf-a0-59.ucode
firmware: iwlwifi-SoSnj-a0-hr-b0-59.ucode
firmware: iwlwifi-SoSnj-a0-gf-a0-59.ucode
firmware: iwlwifi-SoSnj-a0-gf4-a0-59.ucode
firmware: iwlwifi-ty-a0-gf-a0-59.ucode
firmware: iwlwifi-so-a0-gf-a0-59.ucode
firmware: iwlwifi-so-a0-hr-b0-59.ucode
firmware: iwlwifi-so-a0-jf-b0-59.ucode
firmware: iwlwifi-cc-a0-59.ucode
firmware: iwlwifi-QuQnj-b0-jf-b0-59.ucode
firmware: iwlwifi-QuZ-a0-jf-b0-59.ucode
firmware: iwlwifi-QuZ-a0-hr-b0-59.ucode
firmware: iwlwifi-Qu-b0-jf-b0-59.ucode
firmware: iwlwifi-Qu-c0-hr-b0-59.ucode
firmware: iwlwifi-QuQnj-b0-hr-b0-59.ucode
firmware: iwlwifi-Qu-b0-hr-b0-59.ucode
alias: pci:v00008086d00007E80svsdbcsci*
alias: pci:v00008086d00002729svsdbcsci*
alias: pci:v00008086d00007AF0svsd00000A10bcsci
alias: pci:v00008086d00007AF0svsd00000510bcsci
alias: pci:v00008086d00007AF0svsd00000310bcsci
alias: pci:v00008086d00007AF0svsd000000B0bcsci
alias: pci:v00008086d00007AF0svsd00000098bcsci
alias: pci:v00008086d00007AF0svsd00000090bcsci
alias: pci:v00008086d00007A70svsd00000A10bcsci
alias: pci:v00008086d00007A70svsd00000510bcsci
alias: pci:v00008086d00007A70svsd00000310bcsci
alias: pci:v00008086d00007A70svsd000000B0bcsci
alias: pci:v00008086d00007A70svsd00000098bcsci
alias: pci:v00008086d00007A70svsd00000090bcsci
alias: pci:v00008086d00002726svsd00004070bcsci
alias: pci:v00008086d00002726svsd00002074bcsci
alias: pci:v00008086d00002726svsd00000510bcsci
alias: pci:v00008086d00002726svsd000000B0bcsci
alias: pci:v00008086d00002726svsd00000098bcsci
alias: pci:v00008086d00002726svsd00000090bcsci
alias: pci:v00008086d00002726svsd0000007Cbcsci
alias: pci:v00008086d00002726svsd00000078bcsci
alias: pci:v00008086d00002726svsd00000074bcsci
alias: pci:v00008086d00002726svsd00000070bcsci
alias: pci:v00008086d00002725svsd000000B0bcsci
alias: pci:v00008086d00002725svsd00006024bcsci
alias: pci:v00008086d00002725svsd00006020bcsci
alias: pci:v00008086d00002725svsd00004020bcsci
alias: pci:v00008086d00002725svsd0000E024bcsci
alias: pci:v00008086d00002725svsd0000E020bcsci
alias: pci:v00008086d00002725svsd00000A10bcsci
alias: pci:v00008086d00002725svsd00000510bcsci
alias: pci:v00008086d00002725svsd00000310bcsci
alias: pci:v00008086d00002725svsd00000024bcsci
alias: pci:v00008086d00002725svsd00000020bcsci
alias: pci:v00008086d00002725svsd00000090bcsci
alias: pci:v00008086d00002723svsdbcsci*
alias: pci:v00008086d00002720svsdbcsci*
alias: pci:v00008086d0000A0F0svsdbcsci*
alias: pci:v00008086d000043F0svsdbcsci*
alias: pci:v00008086d00004DF0svsdbcsci*
alias: pci:v00008086d00003DF0svsdbcsci*
alias: pci:v00008086d000034F0svsdbcsci*
alias: pci:v00008086d000006F0svsdbcsci*
alias: pci:v00008086d000002F0svsdbcsci*
alias: pci:v00008086d0000A370svsdbcsci*
alias: pci:v00008086d00009DF0svsdbcsci*
alias: pci:v00008086d000031DCsvsdbcsci*
alias: pci:v00008086d000030DCsvsdbcsci*
alias: pci:v00008086d0000271Csvsdbcsci*
alias: pci:v00008086d0000271Bsvsdbcsci*
alias: pci:v00008086d00002526svsdbcsci*
alias: pci:v00008086d000024FDsvsd00009074bcsci
alias: pci:v00008086d000024FDsvsd00000014bcsci
alias: pci:v00008086d000024FDsvsd00000012bcsci
alias: pci:v00008086d000024FDsvsd00001012bcsci
alias: pci:v00008086d000024FDsvsd00003E01bcsci
a lot of alias lines- i removedto save space

depends: cfg80211
retpoline: Y
intree: Y
name: iwlwifi
vermagic: 5.10.76-1.fc32.qubes.x86_64 SMP mod_unload
sig_id: PKCS#7
signer: Build time autogenerated kernel key
sig_key: 7C:90:2C:05:87:42:A5:3D:C2:F7:DC:4B:69:1A:1F:0D:F9:52:DF:2B
sig_hashalgo: sha256
signature: 79:D2:E1:A4:24:20:4B:3E:B9:4A:68:E6:00:9F:3F:4B:F6:87:6D:A4:
84:02:90:84:83:18:23:D5:F8:B6:10:85:57:FF:AB:02:35:FE:20:00:
10:F0:1D:B0:D6:00:45:08:8B:46:9E:FC:82:27:7B:12:B3:C3:8C:BB:
70:80:00:4C:04:0C:27:5A:4F:E3:F0:79:E8:2B:40:AE:04:D2:35:1B:
93:9A:F4:36:0A:11:6E:35:9A:CF:26:34:09:32:2C:6D:E6:E7:17:30:
39:22:27:25:AD:EC:88:A5:9E:83:01:89:5B:CC:49:99:16:DD:9F:3D:
7B:C0:6C:F6:6F:47:B3:AD:89:E3:86:B1:4F:9A:5A:82:87:44:6A:80:
4C:F6:F5:85:2B:49:A2:2B:F8:FD:D5:DC:00:84:6B:B0:81:BB:2D:21:
BC:90:AF:F0:06:41:76:26:CC:EA:8B:3F:79:3C:41:FB:76:9E:C4:36:
1E:4A:D1:C5:1A:0B:95:40:3F:D2:B4:15:AB:A5:C2:DB:FA:E8:1A:82:
09:B8:B4:BC:A5:80:6D:64:78:BB:5F:4B:F5:FC:27:86:BC:17:76:79:
E8:55:F9:FD:AB:9A:20:6E:36:EF:FD:89:8B:48:8D:B9:A5:D6:62:E7:
11:51:1D:40:10:EE:64:AA:48:95:3C:88:08:ED:9C:BA:98:56:B0:B6:
DC:D8:38:B9:34:23:FD:48:68:4E:72:B7:B5:CF:30:00:FB:E4:F8:61:
9D:B2:52:D3:EF:58:0C:F3:73:57:C1:98:05:11:51:46:69:1B:99:51:
E0:DF:48:A1:8A:C0:20:B8:3B:62:10:CD:48:32:F5:E7:86:85:F8:67:
29:AE:2E:4B:67:D3:0D:8D:3D:C2:86:28:9B:CA:D3:57:83:DE:11:3A:
D8:1A:F0:AA:CC:9C:1A:33:F4:0C:60:2F:C6:C9:3E:A2:F5:30:AC:DB:
75:B8:6F:8B:89:49:44:14:74:15:45:07:FA:3E:6D:22:24:51:4B:EF:
DE:DF:E8:12:DA:D8:CA:79:01:08:54:13:7E:A8:41:4A:3C:EE:93:3D:
59:65:06:01:F8:65:D8:DB:F0:45:07:7D:84:E3:86:D4:9E:19:28:27:
A9:71:30:5E:E9:A3:CB:4F:D6:D4:89:51:A9:D7:3F:4A:61:25:FE:4C:
44:75:EF:78:62:0B:0C:98:CC:A8:74:09:10:26:2F:0F:7F:25:2F:8D:
56:FF:47:11:F6:E9:8C:87:FB:B7:28:6C:C4:E9:CD:13:45:F9:7A:44:
6B:C1:1B:4C:30:13:FF:BB:2C:EB:4A:C8:78:17:53:26:8E:05:26:86:
E6:D3:40:33:D6:A4:8B:27:64:96:D6:77
parm: debug:debug output mask (uint)
parm: swcrypto:using crypto in software (default 0 [hardware]) (int)
parm: 11n_disable:disable 11n functionality, bitmap: 1: full, 2: disable agg TX, 4: disable agg RX, 8 enable agg TX (uint)
parm: amsdu_size:amsdu size 0: 12K for multi Rx queue devices, 2K for AX210 devices, 4K for other devices 1:4K 2:8K 3:12K 4: 2K (default 0) (int)
parm: fw_restart:restart firmware in case of error (default true) (bool)
parm: nvm_file:NVM file name (charp)
parm: uapsd_disable:disable U-APSD functionality bitmap 1: BSS 2: P2P Client (default: 3) (uint)
parm: enable_ini:Enable debug INI TLV FW debug infrastructure (default: true (bool)
parm: bt_coex_active:enable wifi/bt co-exist (default: enable) (bool)
parm: led_mode:0=system default, 1=On(RF On)/Off(RF Off), 2=blinking, 3=Off (default: 0) (int)
parm: power_save:enable WiFi power management (default: disable) (bool)
parm: power_level:default power save level (range from 1 - 5, default: 1) (int)
parm: disable_11ac:Disable VHT capabilities (default: false) (bool)
parm: remove_when_gone:Remove dev from PCIe bus if it is deemed inaccessible (default: false) (bool)
parm: disable_11ax:Disable HE capabilities (default: false) (bool)

Oh thanks yes, you turned on my wifi!

Qubes domains Qube manager settings of template and changing to fedora or right click to change template.
Even better shut down is here then from notification. In here it asks do i want to shutdown all related ones. In notifications only one by one i can.
So i changed to Fedora and works- auto connected since in nm-applet i already put all credentials.
But i havend tried fedora, since dont want to learn too confusing commands, but for testing i installed without removing fedora. What to do to thouse who didnt installed Fedora?
So then theres Debian thing bug then we have found.
Also did one more command- maybe this helps to find bug?

dmesg in net-sys shows some error

[    3.746288] iwlwifi 0000:00:06.0: Direct firmware load for iwlwifi-8000C-36.ucode failed with error -2

Here about error -33 but debian users get (as i got now here got) -36

Theres mentioned to install sudo apt install linux-firmware but i get E: Unable to locate package linux-firmware

TL:DR dmesg wifi error TL:DR part of error i see related to wifi
dmesg TL full result dmesg TL full result - Pastebin.com but i copied out main things i understood that are around wifi.
Since this error is at end of dmesh then copied till end and a bit before error lines where i think its about wifi

[    2.696771] Adding 1048572k swap on /dev/xvdc1.  Priority:-2 extents:1 across:1048572k SSFS
[    2.770626] EXT4-fs (xvda3): re-mounted. Opts: discard
[    2.772395] lp: driver loaded but no devices found
[    2.786324] systemd-journald[226]: Received client request to flush runtime journal.
[    2.790356] ppdev: user-space parallel port driver
[    2.822780] xen:xen_evtchn: Event-channel device installed
[    2.886912] memmap_init_zone_device initialised 32768 pages in 0ms
[    3.229922] FDC 0 is a S82078B
[    3.255016] piix4_smbus 0000:00:01.3: SMBus Host Controller not enabled!
[    3.317061] e1000e: Intel(R) PRO/1000 Network Driver
[    3.317085] e1000e: Copyright(c) 1999 - 2015 Intel Corporation.
[    3.318609] xen: --> pirq=16 -> irq=44 (gsi=44)
[    3.322329] e1000e 0000:00:07.0: Interrupt Throttling Rate (ints/sec) set to dynamic conservative mode
[    3.349127] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    3.357030] ehci-pci: EHCI PCI platform driver
[    3.360602] ehci-pci 0000:00:05.0: EHCI Host Controller
[    3.372595] ehci-pci 0000:00:05.0: new USB bus registered, assigned bus number 1
[    3.374205] ehci-pci 0000:00:05.0: irq 39, io mem 0xf2035000
[    3.382727] ehci-pci 0000:00:05.0: USB 2.0 started, EHCI 1.00
[    3.386224] input: PC Speaker as /devices/platform/pcspkr/input/input5
[    3.406537] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002, bcdDevice= 5.10
[    3.406590] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    3.406620] usb usb1: Product: EHCI Host Controller
[    3.406640] usb usb1: Manufacturer: Linux 5.10.76-1.fc32.qubes.x86_64 ehci_hcd
[    3.406683] usb usb1: SerialNumber: 0000:00:05.0
[    3.425644] cfg80211: Loading compiled-in X.509 certificates for regulatory database
[    3.446992] hub 1-0:1.0: USB hub found
[    3.447983] hub 1-0:1.0: 6 ports detected
[    3.465777] Error: Driver 'pcspkr' is already registered, aborting...
[    3.512843] e1000e 0000:00:07.0 0000:00:07.0 (uninitialized): registered PHC clock
[    3.578254] e1000e 0000:00:07.0 eth0: (PCI Express:2.5GT/s:Width x1) 84:7b:eb:2a:1c:d3
[    3.578318] e1000e 0000:00:07.0 eth0: Intel(R) PRO/1000 Network Connection
[    3.578442] e1000e 0000:00:07.0 eth0: MAC: 12, PHY: 12, PBA No: FFFFFF-0FF
[    3.639892] e1000e 0000:00:07.0 ens7: renamed from eth0
[    3.644228] cfg80211: Loaded X.509 cert 'sforshee: 00b28ddf47aef9cea7'
[    3.646462] EXT4-fs (xvdb): mounted filesystem with ordered data mode. Opts: discard
[    3.647316] cfg80211: loaded regulatory.db is malformed or signature is missing/invalid
[    3.739879] Intel(R) Wireless WiFi driver for Linux
[    3.740784] xen: --> pirq=17 -> irq=40 (gsi=40)
[    3.745363] usb 1-1: new high-speed USB device number 2 using ehci-pci
[    3.746288] iwlwifi 0000:00:06.0: Direct firmware load for iwlwifi-8000C-36.ucode failed with error -2
[    3.746302] iwlwifi 0000:00:06.0: Direct firmware load for iwlwifi-8000C-35.ucode failed with error -2
[    3.746314] iwlwifi 0000:00:06.0: Direct firmware load for iwlwifi-8000C-34.ucode failed with error -2
[    3.746325] iwlwifi 0000:00:06.0: Direct firmware load for iwlwifi-8000C-33.ucode failed with error -2
[    3.746337] iwlwifi 0000:00:06.0: Direct firmware load for iwlwifi-8000C-32.ucode failed with error -2
[    3.746349] iwlwifi 0000:00:06.0: Direct firmware load for iwlwifi-8000C-31.ucode failed with error -2
[    3.746361] iwlwifi 0000:00:06.0: Direct firmware load for iwlwifi-8000C-30.ucode failed with error -2
[    3.746373] iwlwifi 0000:00:06.0: Direct firmware load for iwlwifi-8000C-29.ucode failed with error -2
[    3.746384] iwlwifi 0000:00:06.0: Direct firmware load for iwlwifi-8000C-28.ucode failed with error -2
[    3.746395] iwlwifi 0000:00:06.0: Direct firmware load for iwlwifi-8000C-27.ucode failed with error -2
[    3.746407] iwlwifi 0000:00:06.0: Direct firmware load for iwlwifi-8000C-26.ucode failed with error -2
[    3.746417] iwlwifi 0000:00:06.0: Direct firmware load for iwlwifi-8000C-25.ucode failed with error -2
[    3.746429] iwlwifi 0000:00:06.0: Direct firmware load for iwlwifi-8000C-24.ucode failed with error -2
[    3.746440] iwlwifi 0000:00:06.0: Direct firmware load for iwlwifi-8000C-23.ucode failed with error -2
[    3.746451] iwlwifi 0000:00:06.0: Direct firmware load for iwlwifi-8000C-22.ucode failed with error -2
[    3.746452] iwlwifi 0000:00:06.0: no suitable firmware found!
[    3.746453] iwlwifi 0000:00:06.0: minimum version required: iwlwifi-8000C-22
[    3.746454] iwlwifi 0000:00:06.0: maximum version supported: iwlwifi-8000C-36
[    3.746455] iwlwifi 0000:00:06.0: check git://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git
[    3.905335] usb 1-1: New USB device found, idVendor=0627, idProduct=0001, bcdDevice= 0.00
[    3.905369] usb 1-1: New USB device strings: Mfr=1, Product=3, SerialNumber=10
[    3.905412] usb 1-1: Product: QEMU USB Tablet
[    3.905432] usb 1-1: Manufacturer: QEMU
[    3.905455] usb 1-1: SerialNumber: 42
[    3.929687] input: QEMU QEMU USB Tablet as /devices/pci0000:00/0000:00:05.0/usb1/1-1/1-1:1.0/0003:0627:0001.0001/input/input6
[    3.929788] hid-generic 0003:0627:0001.0001: input,hidraw0: USB HID v0.01 Mouse [QEMU QEMU USB Tablet] on usb-0000:00:05.0-1/input0
[    3.969862] audit: type=1400 audit(1640180780.674:2): apparmor="STATUS" operation="profile_load" profile="unconfined" name="lsb_release" pid=430 comm="apparmor_parser"
[    3.971817] audit: type=1400 audit(1640180780.680:3): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/sbin/haveged" pid=432 comm="apparmor_parser"
[    3.976842] audit: type=1400 audit(1640180780.685:4): apparmor="STATUS" operation="profile_load" profile="unconfined" name="nvidia_modprobe" pid=434 comm="apparmor_parser"
[    3.976913] audit: type=1400 audit(1640180780.685:5): apparmor="STATUS" operation="profile_load" profile="unconfined" name="nvidia_modprobe//kmod" pid=434 comm="apparmor_parser"
[    3.988656] audit: type=1400 audit(1640180780.696:6): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/sbin/cups-browsed" pid=431 comm="apparmor_parser"
[    3.997077] audit: type=1400 audit(1640180780.701:7): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/bin/man" pid=440 comm="apparmor_parser"
[    3.997258] audit: type=1400 audit(1640180780.701:8): apparmor="STATUS" operation="profile_load" profile="unconfined" name="man_filter" pid=440 comm="apparmor_parser"
[    4.037808] audit: type=1400 audit(1640180780.701:9): apparmor="STATUS" operation="profile_load" profile="unconfined" name="man_groff" pid=440 comm="apparmor_parser"
[    4.058767] audit: type=1400 audit(1640180780.765:10): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/cups/backend/cups-pdf" pid=442 comm="apparmor_parser"
[   14.575405] vif vif-28-0 vif28.0: Guest Rx ready
[   14.575438] IPv6: ADDRCONF(NETDEV_CHANGE): vif28.0: link becomes ready
[   37.491696] e1000e 0000:00:07.0 ens7: NIC Link is Up 100 Mbps Half Duplex, Flow Control: Rx/Tx
[   37.491780] e1000e 0000:00:07.0 ens7: 10/100 speed: disabling TSO
[   37.493294] e1000e 0000:00:07.0 ens7: NIC Link is Down
[   39.182279] e1000e 0000:00:07.0 ens7: NIC Link is Up 100 Mbps Full Duplex, Flow Control: None
[   39.182401] e1000e 0000:00:07.0 ens7: 10/100 speed: disabling TSO
[   39.182761] IPv6: ADDRCONF(NETDEV_CHANGE): ens7: link becomes ready

Another thing i found here- GPU disabled maybe meakes use more battery?
Windows i had 8h left if using a bit. 12h if not moving.
If using Windows then 6h. If non stop then 4h-2h even.
Qubes OS currently if no battery wrong showing erros then showed 4h, but i didnt let it go to zero, to see if theres no wrong calculations.
Maybe need to disable nomodeset?

[    0.056416] Kernel command line: root=/dev/mapper/dmroot ro nomodeset console=hvc0 rd_NO_PLYMOUTH rd.plymouth.enable=0 plymouth.enable=0 xen_scrub_pages=0  apparmor=1 security=apparmor
[    0.056439] You have booted with nomodeset. This means your GPU drivers are DISABLED
[    0.056440] Any video related functionality will be severely degraded, and you may not even be able to suspend the system properly
[    0.056441] Unless you actually understand what nomodeset does, you should reboot without enabling it

even disabling ethernet can reduce battery consumption. so yes.

And i think editing thread tittle to something like “kangarooo qubes os journal” is preferred. Since there’s a ton of problem and you solve it by yourself :joy:

Yeah, it became a draft for a Qubes Os advertisement it blog post about 1st user testing and how to solve. :smiley:
Also will help new users for multiple problems especially Debian users with Dell latitude e5470 wifi intel 8260. Could be a blog of this specification testing of compatibility.
I thought would be weird for each problem new post.
Maybe could each hw setup have one thread with posts of related problems. Somehow it became like that.
But thouse are things that came up and usual user would not be able to solve, so needs some fixings so works out-of-box.

Another idea- whole Qubes OS website in github is cool so could be imported in installation also, so without internet could browse all. Its showing its only 2.2MB.

But since its possible to install only debian, then if its not working wifi, then that should be fixed to work out-of-box and i still dont know how to fix it in-the-box.

Note: I changed the too long title.

@Kangarooo : please don’t write your life in the title, thank.

The original title was : 4.1 rc3 testing How to Dual Boot Qubes OS with Windows 10 automatic partitioning wizzard? Wifi Not working Dell latitude e5470 UEFI TPM 2.0. UX story: some no indications of system beeing busy, fixing vm domain templates, wifi is installed but not working

1 Like

No worries. Just leave it there. Also this.